Has anyone configured SSL for nginx on CloudMan (AWS)? If so, can you share
your nginx.conf file as I'm having some issues.

I tried adopting the nginx.conf for CloudMan+CloudBioLiniux as described
ran into a problem with the line (in red):

server {
   * listen 443 default_server ssl;*
    ssl_certificate      /usr/nginx/conf/cert;
    ssl_certificate_key  /usr/nginx/conf/key;


According to *nginx.conf.default* the configuration for HTTPS looks like:

*server {*

*listen 443;*

*server_name localhost;*


This suggested that the documentation was incorrect, and that I needed to
insert a semicolon after '*listen 443*'.

*[emerg]: unknown directive "default_server" in

*Returning again to nginx.conf.default I 'replaced default_server ssl' with:

*server {*

*listen 443;*

*server_name localhost;*


After restarting the galaxy server, I hit out server and then directed to *

On the one hand, I'm not surprised that I am directed to localhost, however
I see the same usage for describing the service for port 80.

Nevertheless, in the CloudMan+CloudBioLinux docs following section was to
be added to the port 80 section.

server {
   listen         80;
   server_name    mygalaxy.example.com;
   rewrite        ^ https://$server_name$request_uri? permanent;

so I changed $server_name -> $host. Redirection worked, but there was no
response on the other end. There are several avenues I could take from
here. Any suggestions?

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to