Hi,

I was trying to install the galaxy on my laptop and run into the following
error

Some eggs are out of date, attempting to fetch...
Warning: MarkupSafe (a dependent egg of Mako) cannot be fetched
Warning: pycrypto (a dependent egg of Fabric) cannot be fetched
Warning: simplejson (a dependent egg of WebHelpers) cannot be fetched
Fetched http://eggs.galaxyproject.org/ssh/ssh-1.7.14-py2.7.egg
One of Galaxy's managed eggs depends on something which is missing, this is
almost certainly a bug in the egg distribution.
Dependency "ssh" requires "pycrypto>=2.1,!=2.4"
Traceback (most recent call last):
  File "./scripts/fetch_eggs.py", line 37, in <module>
    c.resolve() # Only fetch eggs required by the config
  File
"/Users/yinan/Course2013Spring/IBOIS58A/galaxy-dist/lib/galaxy/eggs/__init__.py",
line 345, in resolve
    egg.resolve()
  File
"/Users/yinan/Course2013Spring/IBOIS58A/galaxy-dist/lib/galaxy/eggs/__init__.py",
line 168, in resolve
    dists = pkg_resources.working_set.resolve( (
self.distribution.as_requirement(), ), env, self.fetch )
  File "build/bdist.linux-i686/egg/pkg_resources.py", line 569, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (ssh 1.7.14
(/Users/yinan/Course2013Spring/IBOIS58A/galaxy-dist/eggs/ssh-1.7.14-py2.7.egg),
Requirement.parse('pycrypto>=2.1,!=2.4'))
Fetch failed.

Because I have numpy installed which seems to be conflict to galaxy, so I
was install with virtual python environment (virtualenv), and also tried
the protection environment provided in the galaxy instruction page (
http://wiki.galaxyproject.org/Admin/Config/Performance/ProductionServer),
and both came across the same error as indicated above.

Some information you may be interested:
(GalaxyENV)yinan@Macbook galaxy-dist$ python -V
Python 2.7.3
(GalaxyENV)yinan@Macbook galaxy-dist$ python scripts/get_platforms.py
macosx-10.7-x86_64-ucs2

It will be great if you can help me out.

Thanks,
Yinan

-- 
Yinan Wan, graduate student
Bioinformatics and Genomics program
Huck Institutes of Life Sciences
the Pennsylvania State University
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to