172.17.130.203 - - [19/Apr/2013:10:31:20 -0400] "GET 
/api/datasets/dd61915e24aa3fd0?hda_ldda=hda&data_type=converted_datasets_state&chrom=chr1
 HTTP/1.1" 200 - 
"http://galaxy.neb.com/visualization/trackster?dataset_id=b8edc02014d74add&hda_ldda=hda";
 "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, 
like Gecko) Chrome/26.0.1410.65 Safari/537.31"
galaxy.webapps.galaxy.api.datasets ERROR 2013-04-19 10:31:21,775 Error in 
dataset API at listing contents: unpack requires a string argument of length 4: 
unpack requires a string argument of length 4
Traceback (most recent call last):
  File 
"/mnt/ngswork/galaxy/galaxy-dist/lib/galaxy/webapps/galaxy/api/datasets.py", 
line 41, in show
    is_true( kwd.get( 'retry', False ) ) )
  File 
"/mnt/ngswork/galaxy/galaxy-dist/lib/galaxy/webapps/galaxy/api/datasets.py", 
line 96, in _converted_datasets_state
    if not data_provider.has_data( chrom ):
  File 
"/mnt/ngswork/galaxy/galaxy-dist/lib/galaxy/visualization/data_providers/genome.py",
 line 1037, in has_data
    f, bbi = self._get_dataset()
  File 
"/mnt/ngswork/galaxy/galaxy-dist/lib/galaxy/visualization/data_providers/genome.py",
 line 1170, in _get_dataset
    return f, BigWigFile(file=f)
  File "bigwig_file.pyx", line 127, in bx.bbi.bigwig_file.BigWigFile.__init__ 
(lib/bx/bbi/bigwig_file.c:3011)
  File "bbi_file.pyx", line 119, in bx.bbi.bbi_file.BBIFile.__init__ 
(lib/bx/bbi/bbi_file.c:3508)
  File "bbi_file.pyx", line 129, in bx.bbi.bbi_file.BBIFile.open 
(lib/bx/bbi/bbi_file.c:3660)
  File 
"/mnt/ngswork/galaxy/galaxy-dist/eggs/bx_python-0.7.1_7b95ff194725-py2.6-linux-x86_64-ucs4.egg/bx/misc/binary_file.py",
 line 30, in __init__
    if struct.unpack( ">I", bytes )[0] == magic:
error: unpack requires a string argument of length 4

Is this a bug or have I done something unexpected?


I'm trying to use the trackbrowser to visualize some bam files that I aligned 
to a genome that I had to install manually (Zea_mays_B73_RefGen_v2), maybe i've 
screwed something up.

I was initially able to see some reads, but after reverting to the sample 
datatypes file and restarting galaxy i can't see anything anymore.
I also added  a .2bit file to twobit.locs
Zea_mays_AGPv2 
/mnt/ngswork/galaxy/galaxy-dist/tool-data/genome/Zea_mays_AGPv2/seq/Zea_mays_AGPv2.2bit

maybe that's related...

I've tried copying the bams to a new history  - and they seem to be reindexing 
as a result, but I still see no reads.



Any ideas?



Brad
--
Brad Langhorst
langho...@neb.com<mailto:langho...@neb.com>





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to