On Thu, May 9, 2013 at 10:59 AM, Peter Cock <p.j.a.c...@googlemail.com> wrote:
>
> On Thu, May 9, 2013 at 10:49 AM, Peter Cock <p.j.a.c...@googlemail.com> wrote:
> >
> > Hi Dave,
> >
> > As you hoped, these test now shows up on the tool page (as expected
> > they are test failures - apparently my install script isn't quite right 
> > yet):
> >
> > ...
> >
> > This one is more interesting, and appears to be a problem with the
> > test framework (both tests pass locally via run_functional_tests.sh):
> >
> > http://testtoolshed.g2.bx.psu.edu/view/peterjc/seq_rename/16a1a5ae98e9
> > Functional test results for changeset revision 16a1a5ae98e9 of seq_rename
> > 0 tests passed, 2 tests failed, 0 tests missing test components.
> >
> > I'll raise that on a new thread,
>
> Here's the output from the (Test) Tool Shed where the tests fail:
>
> ...
>
> Both tests fail with the following assertion:
>
> AssertionError: Attempting to set field 'new_column' to value '['c2']' in form
> 'tool_form' threw exception: cannot find value/label "c2" in list control 
> control:
> <SelectControl(new_column=[1])> If the above control is a DataToolparameter
> whose data type class does not include a sniff() method, make sure to include
> a proper 'ftype' attribute to the tag for the control within the <test> tag 
> set.
>
> Both tests pass on my development machine run via:
>
> $ ./run_functional_tests.sh -id seq_rename
>
> The two tests are defined as follows - identical bar the style used for the 
> column
> arguments - I was wondering if the Tool Shed testing was stricter about 
> numeric
> column names, but that does not seem to be relevant:
>
>     <tests>
>         <test>
>             <param name="input_file" value="four_human_proteins.fasta" 
> ftype="fasta" />
>             <param name="input_tabular" 
> value="four_human_proteins.rename.tabular" ftype="tabular" />
>             <param name="old_column" value="1" />
>             <param name="new_column" value="2" />
>             <output name="output_file" 
> file="four_human_proteins.rename.fasta" ftype="fasta" />
>         </test>
>         <test>
>             <param name="input_file" value="four_human_proteins.fasta" 
> ftype="fasta" />
>             <param name="input_tabular" 
> value="four_human_proteins.rename.tabular" ftype="tabular" />
>             <param name="old_column" value="c1" />
>             <param name="new_column" value="c2" />
>             <output name="output_file" 
> file="four_human_proteins.rename.fasta" ftype="fasta" />
>         </test>
>     </tests>
>
> I can retest with the latest galaxy-dist once this issue is resolved:
> http://lists.bx.psu.edu/pipermail/galaxy-dev/2013-May/014557.htm

Correction, I'm trying to update to the latest galaxy-central (I was
using f8d07c98812903dc98de2665874a2c31b65b84da from
 2013-04-29 where these tests pass).

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to