Hi guys,

another error appeared after we installed NCBI BLAST + to our local Galaxy 
instance and wanted to test it.
After uploading some testdata to our history we tried to run blastn on it and 
got the following error:
Fatal error: Matched on Error:
Error: NCBI C++ Exception:
    
"/opt/galaxy/galaxy-dist/database/tmp/tmphx2DHp/ncbi-blast-2.2.26+-src/c++/src/corelib/ncbiobj.cpp",
 line 689: Critical: ncbi::CObject::ThrowNullPointerException() - Attempt to 
access NULL pointer.

With some testing around we figure out the problem:

./blastn -query ~/test.fasta -db nt -task blastn -evalue 0.001 -out ~/out2.txt 
-outfmt "6 std sallseqid score nident positive gaps ppos qframe sframe qseq 
sseq qlen slen" -num_threads 8
Doesn't work until we replaced the "num_threads 8" like it is written in the 
original "ncbi_blastn_wrapper.xml" with "num_threads 1"
Editing the .xml also solved the problem within the galaxy surface.
Now my question is, is there any other workaround without editing the" 
ncbi_blastn_wrapper.xml"?
Searching in the documentation and the mailing list, I did not find anything 
about this.
We believe this could be of common interest. It would be great if anybody could 
comment on this.

Thanks a lot, Thomas

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to