Hi all,

I'm currently trying to set up a galaxy-dist instance on a SLES server within an 'encapsulated' network (hospital environment; here all sensitive data is stored and handled). Within this network, clients are only capable of accessing the internet via HTTP/HTTPS and FTP, using a proxy - adress and port (8080) are the same for all three protocols.


Mercurial (which I had to set up in advance) is accessible and more or less in default configuration (more on that down below).

What I get after executing the command 'hg clone https://bitbucket.org/galaxy/galaxy-dist#stable'
is
"abort: error: _ssl.c:491: error:140700FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol"

Google search indicates something more general, so outside the exclusive scope of Galaxy. On top, no connection to Galaxy was listed, also not in this mailing list's archive.

Following some hints I just tried to set the proxy via a '.hgrc' file in the galaxy user home like this:
---
[http_proxy]
host = url:port

[https_proxy]
host = url:port
---
(re-login after that) and also set the system variables '$http_proxy' and '$https_proxy'. Another approach described was to call 'hg --config http_proxy.host=url:port clone https://bitbucket.org/galaxy/galaxy-dist#stable'

Nothing worked out.

Does anyone experienced similar behaviour or has got some ideas how to solve this?

Thanks in advance,

Sebastian


--
Sebastian Schaaf, M.Sc. Bioinformatics
University of Munich

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to