Hi all

After updating to the last stable galaxy when I'm trying to upgrade the
database I'm getting the following message:

/steno-internal/projects/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.6-linux-x86_64-ucs4.egg/sqlalchemy/engine/url.py:105:
SADeprecationWarning: The SQLAlchemy PostgreSQL dialect has been renamed
from 'postgres' to 'postgresql'. The new URL format is
postgresql[+driver]://<user>:<pass>@<host>/<dbname>


If I change the line in universe_wsgi.ini from

database_connection = postgres://galaxy:password@localhost:5432/galaxydb

to

database_connection = postgresql://galaxy:password@localhost:5432/galaxydb

I get the following when restarting galaxy.

migrate.versioning.repository DEBUG 2013-07-17 15:23:53,462 Config:
{'db_settings': {'__name__': 'db_settings', 'required_dbs': '[]',
'version_table': 'migrate_version', 'repository_id': 'Galaxy'}}
galaxy.model.migrate.check ERROR 2013-07-17 15:23:53,463
database_connection contains an unknown SQLAlchemy database dialect:
postgresql
Traceback (most recent call last):
  File
"/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/webapps/galaxy/buildapp.py",
line 35, in app_factory
    app = UniverseApplication( global_conf = global_conf, **kwargs )
  File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/app.py",
line 52, in __init__
    create_or_verify_database( db_url, kwargs.get( 'global_conf', {} ).get(
'__file__', None ), self.config.database_engine_options, app=self )
  File
"/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/model/migrate/check.py",
line 50, in create_or_verify_database
    engine = create_engine( url, **engine_options )
  File
"/steno-internal/projects/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.6-linux-x86_64-ucs4.egg/sqlalchemy/engine/__init__.py",
line 338, in create_engine
    return strategy.create(*args, **kwargs)
  File
"/steno-internal/projects/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.6-linux-x86_64-ucs4.egg/sqlalchemy/engine/strategies.py",
line 64, in create
    dbapi = dialect_cls.dbapi(**dbapi_args)
  File
"/steno-internal/projects/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.6-linux-x86_64-ucs4.egg/sqlalchemy/dialects/postgresql/psycopg2.py",
line 312, in dbapi
    psycopg = __import__('psycopg2')
ImportError: No module named psycopg2
Removing PID file web0.pid

I tried to install psycopg2 with no success but I guess it must have
already been there for postgres to work before the renaming.

Is there any (simple) solution to this that I'm missing?

Bests,
Nikos

p.s.: sorry for the first incomplete message



2013/7/17 Nikos Sidiropoulos <nikos.sid...@gmail.com>

> Hi all
>
> After updating to the last stable galaxy when I'm trying to upgrade the
> database I'm getting the following message:
>
> /steno-internal/projects/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.6-linux-x86_64-ucs4.egg/sqlalchemy/engine/url.py:105:
> SADeprecationWarning: The SQLAlchemy PostgreSQL dialect has been renamed
> from 'postgres' to 'postgresql'. The new URL format is
> postgresql[+driver]://<user>:<pass>@<host>/<dbname>
>
>
> If I change the line in universe_wsgi.ini from
>
> database_connection = postgresql://galaxy:password@localhost:5432/galaxydb
>
> to
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to