Hi everyone,

I'm running into a bit of trouble with running functional tests on tool
wrappers for rseqc that I am writing (testing according to the wiki
page<http://wiki.galaxyproject.org/TestingInstalledTools>).
The tools are listed in shed_tool_conf.xml. Though I'm working with ~15
tool wrappers, I'm attaching the error for read_quality.py, which is
recurring for each of the other tools I'm writing. I'm attaching the link
to the xml wrapper for
read_quality<https://gist.github.com/nkav/abae3a22c1e4c881c2d8>to show
you how I write the tests.

Here is the specific error message (this was the same message returned for
the 12 other rseqc tools I had wrapped):

======================================================================
ERROR: test_tool_000000 (
functional.test_toolbox.TestForTool_testtoolshed.g2.bx.psu.edu/repos/nilesh/rseqc_dev2/read_quality/1.0.0
)
Read Quality (
testtoolshed.g2.bx.psu.edu/repos/nilesh/rseqc_dev2/read_quality/1.0.0 ) >
Test-1
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/nilesh/galaxy-dist/test/functional/test_toolbox.py", line
171, in test_tool
    self.do_it( td, shed_tool_id=shed_tool_id )
  File "/home/nilesh/galaxy-dist/test/functional/test_toolbox.py", line 43,
in do_it
    shed_tool_id=shed_tool_id )
  File "/home/nilesh/galaxy-dist/test/base/twilltestcase.py", line 204, in
upload_file
    filename = self.get_filename( filename, shed_tool_id=shed_tool_id )
  File "/home/nilesh/galaxy-dist/test/base/twilltestcase.py", line 179, in
get_filename
    return os.path.abspath( os.path.join( file_dir, filename ) )
  File "/usr/lib/python2.7/posixpath.py", line 77, in join
    elif path == '' or path.endswith('/'):
AttributeError: 'NoneType' object has no attribute 'endswith'
-------------------- >> begin captured stdout << ---------------------

form 'login' contains the following controls ( note the values )


--------------------- >> end captured stdout << ----------------------


I'm using the latest version of Galaxy and the RSeQC package, and the tool
dependencies for rseqc install correctly after downloading from the test
tool shed. Am I forgetting to do something here? Thanks so much for your
help.
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to