The ini file is not a .less file so it will error if you call lessc
directly with it.

It may be that you're lacking some (not obvious) dependencies. Do you have
pyparsing and PIL installed and available in your terminal (pip install
will work with both)?

You can also use npm to update/install your node modules (sudo npm install
-g less) if you have npm installed.


On Mon, Aug 5, 2013 at 11:28 AM, Seth Sims <seth.s...@gmail.com> wrote:

> Dear Carl,
>
>     You are using a more recent version of lessc then I am so it is
> probably just a versioning error. Ubuntu Precise Pangolin's repositories
> are still at lessc-1.2.1. So apparently I need to manually install a more
> recent version of the compiler. Here is a description of the error if
> anyone else has this problem:
>
>     I have not edited anything, when attempting to compile the vanilla
> blue_colors.ini from the repo I receive an error like so:
>
> $sudo lessc blue_colors.ini
> ParseError: Syntax Error on line 1 in
> /srv/galaxy-dist/static/style/blue_colors.ini:1:9
> 1 base_text=#303030
> 2 base_bg_top=#FFFFFF
>
> However the only reason I used that command is because the makefile gives
> a different error:
>
> $ sudo make OUT=blue
> make[1]: Entering directory `/srv/galaxy-dist/static/style/blue'
> lessc -x ../base.less base.css
> TypeError: Cannot call method 'charAt' of undefined
>     at getLocation (/usr/lib/nodejs/less/parser.js:204:34)
>     at new LessError (/usr/lib/nodejs/less/parser.js:213:19)
>     at Object.toCSS (/usr/lib/nodejs/less/parser.js:379:31)
>     at /usr/bin/lessc:103:28
>     at /usr/lib/nodejs/less/parser.js:428:40
>     at /usr/lib/nodejs/less/parser.js:94:48
>     at /usr/lib/nodejs/less/index.js:113:15
>     at /usr/lib/nodejs/less/parser.js:428:40
>     at /usr/lib/nodejs/less/parser.js:94:48
>     at /usr/lib/nodejs/less/index.js:113:15
> make[1]: *** [base.css] Error 2
> make[1]: Leaving directory `/srv/galaxy-dist/static/style/blue'
> make: *** [all] Error 2
>
> Which is apparently a bug in the version of lessc I have.
>
>
> On Mon, Aug 5, 2013 at 11:09 AM, Carl Eberhard <carlfeberh...@gmail.com>wrote:
>
>> Hey, Seth
>>
>> I'm using npm less 1.3.3. That error isn't a known issue, no.
>>
>> Is that the full stack trace/error report? Which files have you edited?
>>
>> Thanks,
>> Carl
>>
>>
>>
>> On Tue, Jul 30, 2013 at 2:39 PM, Seth Sims <seth.s...@gmail.com> wrote:
>>
>>> Dear Galaxy devs,
>>>
>>>     I am attempting to create a style directory to match my school's
>>> look and feel. I am mainly trying to get the development environment setup
>>> to do this right now. My current problem is that when I attempt to compile
>>> the standard blue_colors.ini which comes with galaxy I am receiving a
>>> syntax error:
>>>
>>> ParseError: Syntax Error on line 1 in
>>> /srv/galaxy-dist/static/style/blue_colors.ini:1:10
>>> 1 base_text=#303030
>>> 2 base_bg_top=#FFFFFF
>>>
>>> I have not edited that file at all. So the first question is, what
>>> version of lessc is being used to compile the styles for the basic
>>> installation? Also are there any pitfalls I should be aware of with this
>>> process.
>>>
>>> - Seth
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>>   http://lists.bx.psu.edu/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>>   http://galaxyproject.org/search/mailinglists/
>>>
>>
>>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to