Rodolfo,

Please keep the thread on the mailing list by using the "Reply all" option.

You should now be able to go to the manage repository page, select the tool dependency, then select 'Manage tool dependencies' from the repository actions dropdown and reinstall the blast+ tool dependency.

   --Dave B.

On 8/5/13 14:03:14.000, Rodolfo Aramayo wrote:
Dear Dave,

Answers below...

On Thu, Aug 1, 2013 at 9:44 AM, Dave Bouvier <d...@bx.psu.edu> wrote:
Rodolfo,

In order to simplify tracking down this issue, could you provide the
changeset revision of Galaxy that is running on tamu.edu? To retrieve the
revision, execute the following command in your galaxy root directory:

hg id

fd4113962c32+ (stable)


To clarify, our understanding is that you installed the ncbi_blast_plus
repository from the main tool shed, and it installed correctly. You then
uninstalled the repository, and it also uninstalled properly. You then
attempted to reinstall the repository, and encountered the error message
cited in your email.

Can you confirm the above?

This is correct


We further understand that the repository is stuck in the 'installing'
state.

YES and in the "Manage installed tool shed repositories" says now
(after having to restart Galaxy for another reason):

"Installed, Missing tool dependencies"


What options are available from the popup menu next to the
ncbi_blast_plus repository on the manage installed repositories page?

  If I click on the little arrow, it says:

Get updates
Deactivate or uninstall

'Deactivate or uninstall' is available, can you try uninstalling again, and
see if that functions correctly?

It worked!

Before I was not able to do it as I was getting an ugly galaxy error page
But now it did uninstall and removed and was able to clone correctly.
However, the directory:

./bioinfosoft/galaxy_dependencies/blast+/2.2.26+/devteam/ncbi_blast_plus/9dabbfd73c8a/bin/

is empty!


Should I repopulate it with the one I have in my backup??

Thanks

--Rodolfo



    --Dave B.


On 8/1/13 07:38:22.000, Rodolfo Aramayo wrote:

People,

I successfully installed NCBI_Blast_Plus from the toolshed
The tool, however, failed to work giving the following error:

Fatal error: Exit code 255 ()
Error: NCBI C++ Exception:

"/usr/local/galaxy/galaxy-dist/database/tmp/tmpwL5OFq/ncbi-blast-2.2.26+-src/c++/src/corelib/ncbiobj.cpp",
line 689: Critical: ncbi::CObject::ThrowNullPointerException() -
Attempt to access NULL pointer.

I then tried uninstalling/reinstalling the tool

However I now get an eternal 'installing' grey message and when I
click 'manage the repo' I get:

#########

URL:
http://galaxy.tamu.edu/admin_toolshed/manage_repository?id=ff08d6222f8e14990ad98c3bdd778cf31920e6108c41c80f
File
'/usr/local/galaxy/galaxy-dist/lib/galaxy/web/framework/middleware/error.py',
line 149 in __call__
    app_iter = self.application(environ, sr_checker)
File
'/usr/local/galaxy/galaxy-dist/eggs/Paste-1.7.5.1-py2.7.egg/paste/recursive.py',
line 84 in __call__
    return self.application(environ, start_response)
File
'/usr/local/galaxy/galaxy-dist/eggs/Paste-1.7.5.1-py2.7.egg/paste/httpexceptions.py',
line 633 in __call__
    return self.application(environ, start_response)
File '/usr/local/galaxy/galaxy-dist/lib/galaxy/web/framework/base.py',
line 132 in __call__
    return self.handle_request( environ, start_response )
File '/usr/local/galaxy/galaxy-dist/lib/galaxy/web/framework/base.py',
line 190 in handle_request
    body = method( trans, **kwargs )
File '/usr/local/galaxy/galaxy-dist/lib/galaxy/web/framework/__init__.py',
line 221 in decorator
    return func( self, trans, *args, **kwargs )
File
'/usr/local/galaxy/galaxy-dist/lib/galaxy/webapps/galaxy/controllers/admin_toolshed.py',
line 561 in manage_repository
    repository = suc.get_installed_tool_shed_repository( trans,
repository_id )
File
'/usr/local/galaxy/galaxy-dist/lib/tool_shed/util/shed_util_common.py',
line 515 in get_installed_tool_shed_repository
    return trans.sa_session.query( trans.model.ToolShedRepository ).get(
trans.security.decode_id( id ) )
File '/usr/local/galaxy/galaxy-dist/lib/galaxy/web/security/__init__.py',
line 60 in decode_id
    return int( self.id_cipher.decrypt( obj_id.decode( 'hex' ) ).lstrip(
"!" ) )
ValueError: invalid literal for int() with base 10: 'cb73864b36ce6a1b'

#########

How can I totally uninstall and re-install this tool?

Thanks
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
    http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
    http://galaxyproject.org/search/mailinglists/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to