Peter,

I apologize for the delay, here is the information you requested:

ubuntu@ip-10-0-0-243:~$ uname -a
Linux ip-10-0-0-243 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
ubuntu@ip-10-0-0-243:~$ arch
x86_64
ubuntu@ip-10-0-0-243:~$ echo $0
-bash

   --Dave B.

On 08/26/2013 09:44 AM, Peter Cock wrote:
(Off list)

Hi Dave, Greg,

Just a reminder - without a bit more information about the Tool Shed
cluster I am stuck about how to debug this install issue.

Thanks,

Peter


On Wed, Aug 21, 2013 at 2:05 PM, Peter Cock <p.j.a.c...@googlemail.com> wrote:
On Wed, Aug 21, 2013 at 1:45 PM, Dave Bouvier <d...@bx.psu.edu> wrote:
Peter,

Here is the relevant log output for the installation of ncbi_blast_plus. A
quick google informs me that exit code 64 means "command line usage error",
for what it's worth.

...
tool_shed.util.shed_util_common DEBUG 2013-08-20 23:34:47,886 Adding new row
(or updating an existing row) for repository 'package_blast_plus_2_2_26' in
the tool_shed_repository table, status set to 'New'.

Warning: local() encountered an error (return code 64) while executing '
                     if [[ "$(uname)" == "Linux" ]]; then export
FILENAME="ncbi-blast-2.2.26+-ia32-linux.tar.gz"; fi &&
                     if [[ "$(arch)" == "x86_64" ]]; then export
FILENAME="ncbi-blast-2.2.26+-x64-linux.tar.gz"; fi &&
                     if [[ "$(uname)" == "Darwin" ]]; then export
FILENAME="ncbi-blast-2.2.26+-universal-macosx.tar.gz"; fi &&
                     echo Fetching $FILENAME &&
                     if [[ "$(uname)" == "Linux" ]]; then wget
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.2.26/$FILENAME; fi &&
                     if [[ "$(uname)" == "Darwin" ]]; then curl -O
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.2.26/$FILENAME; fi &&
                     tar -zxvf $FILENAME &&
                     echo Downloaded and decompressed
                 '


Thanks Dave,

I've made a note on this Trello card about exposing the log information
of unsuccessful builds on the Tool Shed,
https://trello.com/c/HVGrShnC/1042-tool-shed-should-test-installation-of-packages

Can you tell me what version of Linux this is, and which shell?

$ uname
...

$ arch
...

$ echo $0
...

That might give me a clue about the nature of the failure. My
hunch is that I am using something bash specific.

The simplest solution would be if you could run each of these
command by hand to see if it triggers the same error:

if [[ "$(uname)" == "Linux" ]]; then export 
FILENAME="ncbi-blast-2.2.26+-ia32-linux.tar.gz"; fi
if [[ "$(arch)" == "x86_64" ]]; then export 
FILENAME="ncbi-blast-2.2.26+-x64-linux.tar.gz"; fi
if [[ "$(uname)" == "Darwin" ]]; then export 
FILENAME="ncbi-blast-2.2.26+-universal-macosx.tar.gz"; fi
echo Fetching $FILENAME
if [[ "$(uname)" == "Linux" ]]; then wget 
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.2.26/$FILENAME; fi
if [[ "$(uname)" == "Darwin" ]]; then curl -O 
ftp://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.2.26/$FILENAME; fi
tar -zxvf $FILENAME
echo Downloaded and decompressed

Thanks,

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to