Hi Galaxians,

I've been scratching a bit my head about how galaxy builds dependency, fruitlessly so far... Here is my problem: I have a local tool (not installed through a toolshed) that makes use of another tool (aragorn) that I installed from the toolshed.


Aragorn requires the aragorn package, as stated in its .xml file:

<requirement type="package" version="1.2.36">aragorn</requirement>

When I run aragorn, it runs fine, and the dependencies are built fine.

galaxy.tools DEBUG 2013-09-05 12:20:14,340 Building dependency shell command for dependency 'aragorn'


Now when I run my tool, which has the exact same requirement line:

<requirement type="package" version="1.2.36">aragorn</requirement>

the dependency is not built correctly, and fail to resolve:
galaxy.tools DEBUG 2013-09-05 12:26:22,823 Building dependency shell command for dependency 'aragorn' galaxy.tools WARNING 2013-09-05 12:26:22,823 Failed to resolve dependency on 'aragorn', ignoring

The required package is installed in galaxy-dist/tool-dependency-dir/aragorn/1.2.36/bgruening/trna_prediction/d34f31cbc9dd/ and there is an env.sh there that points correctly to the binaries. Now if I copy that env.sh file into galaxy-dist/tool-dependency-dir/aragorn/1.2.36/, it works fine and the dependency command is built all fine, but it is not done automatically when I install aragorn through the toolshed.

Am I doing something wrong? Missing something somewhere?

Cheers,

Lionel
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to