Hi Dave,

The nightly tests for my tools using Biopython are mostly working, e.g.

http://testtoolshed.g2.bx.psu.edu/view/peterjc/seq_filter_by_id
http://testtoolshed.g2.bx.psu.edu/view/peterjc/seq_rename

However, I had an odd failure last night:

http://testtoolshed.g2.bx.psu.edu/view/peterjc/seq_select_by_id/9e9e3b860aa0

Automated tool test results

Tool test results
Automated test environment
Time tested: ~ 11 hours ago
System: Linux 3.0.0-1-amd64
Architecture: x86_64
Python version: 2.7.2+
Galaxy revision: 11038:315018626d87
Galaxy database version: 117
Tool shed revision: 11020:95815478f355
Tool shed database version: 21
Tool shed mercurial version: 2.2.3
Tests that failed
Tool id: seq_select_by_id
Tool version: seq_select_by_id
Test: test_tool_000000
(functional.test_toolbox.TestForTool_testtoolshed.g2.bx.psu.edu/repos/peterjc/seq_select_by_id/seq_select_by_id/0.0.6)
Stderr:
Fatal error: Exit code 1 ()
Biopython 1.54 or later is required
Traceback:
Traceback (most recent call last):
  File 
"/var/opt/buildslaves/buildslave-ec2-1/buildbot-install-test-test-tool-shed-py27/build/test/functional/test_toolbox.py",
line 171, in test_tool
    self.do_it( td, shed_tool_id=shed_tool_id )
  File 
"/var/opt/buildslaves/buildslave-ec2-1/buildbot-install-test-test-tool-shed-py27/build/test/functional/test_toolbox.py",
line 102, in do_it
    self.verify_dataset_correctness( outfile, hid=elem_hid,
maxseconds=testdef.maxseconds, attributes=attributes,
shed_tool_id=shed_tool_id )
  File 
"/var/opt/buildslaves/buildslave-ec2-1/buildbot-install-test-test-tool-shed-py27/build/test/base/twilltestcase.py",
line 782, in verify_dataset_correctness
    self._assert_dataset_state( elem, 'ok' )
  File 
"/var/opt/buildslaves/buildslave-ec2-1/buildbot-install-test-test-tool-shed-py27/build/test/base/twilltestcase.py",
line 606, in _assert_dataset_state
    raise AssertionError( errmsg )
AssertionError: Expecting dataset state 'ok', but state is 'error'.
Dataset blurb: error


There are no installation problems shown, yet the Biopython
import line inside seq_select_by_id.py is failing.

Could you send me the logs from this failure? Perhaps we
have a silent installation failure?

Thanks,

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to