Hi Peter,

Thanks for the zippy response. I had failed to previously install those 
wrappers at all, it looks like. I copied my galaxy-dist folder to another host 
to test and forgot to install some of the shed tools.

Much appreciated!

Carrie Ganote
________________________________________
From: Peter Cock [p.j.a.c...@googlemail.com]
Sent: Wednesday, October 30, 2013 5:59 PM
To: Ganote, Carrie L
Cc: galaxy-dev@lists.bx.psu.edu
Subject: Re: Blastdb and blastdbp datatypes not enforced

On Wed, Oct 30, 2013 at 9:22 PM, Ganote, Carrie L <cgan...@iu.edu> wrote:
> Hi List,
>
> It seems that the blastdb and blastdbp data format is not respected on my
> local install; is it just not generally defined, or am I missing something
> in /lib/galaxy/datatypes or in datatypes_conf?
>
> The most recent blasp wrapper includes this for the input parameter:
> type="data" format="blastdbp"
>
> When I choose the BLAST Database from history option for db, I get every
> valid dataset in my history in the list. Is this because it's a composite
> set?
>
> Thanks for any tips,
>
> Carrie Ganote

You need to install the blastdbn and blastdbp datatypes, available here:
http://toolshed.g2.bx.psu.edu/view/devteam/blast_datatypes

If yours is an old Galaxy instance, the migration scripts might have
done that for you (the BLAST+ wrappers used to be included
within Galaxy), but at that time the blast_datatypes just included
blastxml support.

Peter

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to