Dear Galaxy developers, 

I know I am not the only one with this issue, as over time I've stumbled 
on a few mailing-list threads with other users having the same problem.
And I know the recommended solution is to use the -noac mount option. (
http://wiki.galaxyproject.org/Admin/Config/Performance/Cluster#Unified_Method%29
)

However, it is said that using this -noac mount option comes with a 
performance trade-off, so when we first ran into this issue (datasets 
showing "Empty" and "No peek", even though the file on the hard drive is 
full of content), we implemented the hack found in this thread: 
http://dev.list.galaxyproject.org/What-s-causing-this-error-td4141958.html#a4141963

In this thread, John suggested to add a "sleep()" in the "finish_job" 
method of the "galaxy_dist/lib/galaxy/jobs/runnersdrmaa.py" file.
It worked very well for us. Adding a sleep(30) made all the jobs waiting 
30 seconds before finishing, but the "No peek" issue had at least 
disappear).

However, since the latest Galaxy updates, this file (drmaa.py) has been 
dramastically changed and the "finish_job" method doesn't exist anymore.
Hence, I had to remove this hack, hoping that this issue would have 
disappeared as well.  Unfortunaley, this "No peek" issue is still there 
and causing many headaches to some of our workflows users.

My question is then: Can I put this "sleep(30)" in some other place 
(method and/or file) in order to achieve the same result?
I would really like to solve this "No peek" issue without resorting to the 
"-noac" mount option.  Actually, I am not even sure our system 
administrator would allow it.

Thanks again for your help!
Jean-Fran├žois
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to