Hello Peter,

Yesterday we discovered what Björn has communicated and added it to the Trello 
card for this issue:

https://trello.com/c/sN2iLCCn/99-bug-in-install-and-test-framework-1

It also seems that your tool is attempting to use samtools.  Tgis is in your 
config:

    <requirements>
        <requirement type="binary">samtools</requirement>
        <requirement type="package" version="0.1.19">samtools</requirement>
    </requirements>

and this is in your script:

#Run samtools idxstats:
cmd = "samtools idxstats %s > %s" % (bam_file, tabular_filename)
return_code = os.system(cmd)

I belive a fix for this would be to change the name of your 
repository_dependencies.xml fie to be tool_dependencies.xml, and change the 
current contents of the file to define a complext repository dependencies for 
samtools.  So the current contents of your repository_dependencies.xml file:

<?xml version="1.0"?>
<repositories description="This requires the samtools 0.1.19 binaries">
    <repository changeset_revision="54195f1d4b0f" 
name="package_samtools_0_1_19" owner="iuc" 
toolshed="http://testtoolshed.g2.bx.psu.edu"; />
</repositories>

becomes the following in your renamed tool_dependencies.xml file:

<tool_dependency>
    <package name="samtools" version="0.1.9">
        <repository name="package_samtools_0_1_19" owner="iic" />
    </package>
</tool_dependency>

This is all discussed in the following section of the Tool Shed wiki:

http://wiki.galaxyproject.org/ToolShedToolFeatures#Automatic_third-party_tool_dependency_installation_and_compilation_with_installed_repositories

Let me know if this doesn't correct this problem.

Thanks,

Greg Von Kuster

On Nov 13, 2013, at 6:47 AM, Peter Cock <p.j.a.c...@googlemail.com> wrote:

> On Wed, Nov 13, 2013 at 10:43 AM, Björn Grüning
> <bjoern.gruen...@pharmazie.uni-freiburg.de> wrote:
>> Hi Peter,
>> 
>> sorry for coming late to this thread.
>> 
>> I may be wrong, but you are only specifying a repository_dependecies.xml
>> file. You probably only need to rename it to tool_dependencies.xml file,
>> otherwise the tool can not import it. I guess the env.sh file is not
>> created if no tool_dependencies.xml file is present.
> 
> Yes, I think you are right about repository_dependecies.xml versus
> tool_dependencies.xml but that would happen later - at this point
> my tool hasn't actually tried to use samtools itself.
> 
> Thanks,
> 
> Peter
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/
> 
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/
> 

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to