Hi All,

I‘m seeing some weird error messages...I googled but didn't see anything

So, it is during the wigToBigwig conversion:

Dataset generation errors
Dataset 47: Wig/BedGraph-to-bigWig on data 43
Tool execution generated the following error message:
grep: writing output: Broken pipe
grep: writing output: Broken pipe
grep: writing output: Broken pipe
and many more lines of the same error

The tool produced the following additional output:
Couldn't open tool-data/shared/ucsc/chrom/mm10.len , No such file or

but it is there:

ls -l tool-data/shared/ucsc/chrom/mm10.len

-rw-rw-r-- 1 bioinfoadmin bioinfoadmin 1405 Oct  9 11:33

>From the Galaxy server log, I found these:

galaxy.tools WARNING 2013-11-15 17:46:43,200 Failed to resolve dependency
on 'ucsc_tools', ignoring

galaxy.jobs.runners.local DEBUG 2013-11-15 17:46:43,255 (216) executing:
grep -v "^track"
/home/bioinfoadmin/app/galaxy-dist/database/files/000/dataset_458.dat |
wigToBigWig stdin tool-data/shared/ucsc/chrom/mm10.len
-blockSize=256 -itemsPerSlot=1024 -clip      2>&1 || echo "Error running
wigToBigWig." >&2

and then, setmetadata set the dataset state to ERROR.

I did verify that the result dataset_473.dat has a size 0.

However, when I run the command alone:

grep -v "^track"
| wigToBigWig stdin tool-data/shared/ucsc/chrom/mm10.len
-blockSize=256 -itemsPerSlot=1024 -clip

it successfully generated the dataset_473.dat.

also, I look into the wig_to_Bigwig.xml in tools/filters, the command is:

grep -v "^track" $input1 | wigToBigWig stdin $chromInfo $out_file1

however, I don't see where this "$chromInfo" was defined, yet it indeed
found the

the correct value: tool-data/shared/ucsc/chrom/mm10.len. how does that

it is very puzzling...I'm not sure if anyone has seen this before, please
let me know!


Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to