ah. you are right - I had not updated that older repository - I think I was
waiting for confirmation that the testtoolshed version worked - will do
shortly - thanks for pointing that out!
Try removing that one completely and then installing the test toolshed
version please? That should work until I get the main one updated in a few
hours.


On Mon, Dec 2, 2013 at 9:28 AM, Karen Miga <khm...@soe.ucsc.edu> wrote:

> Yes, I do all of my installs from the toolshed through the admin menu,
> however I did not use the "test toolshed..."  I used the main.  Ah ha -
> maybe that was the issue?
>
> Karen
>
>
> On Sun, Dec 1, 2013 at 2:23 PM, Ross <ross.laza...@gmail.com> wrote:
>
>> Just to confirm, you used automated installation via the admin menu ->
>> search and browse toolsheds -> test toolshed ->  etc ?
>> If you installed manually by downloading and unpacking the archive under
>> your tools/ directory, then yes, there is no automation and you need to
>> install the binary on your path. I believe the documentation explains this
>>  - if it's not clear please suggest some revisions ?
>>
>>
>> On Mon, Dec 2, 2013 at 9:18 AM, Karen Miga <khm...@soe.ucsc.edu> wrote:
>>
>>> Hi Ross,
>>>
>>>   That is listed as "tool_dependency_dir = /mnt/galaxy/tools" in my
>>> universe_wsgi.ini file, and that did not contain a clustalw directory
>>> either before or after the toolshed install.
>>>
>>> Karen
>>>
>>>
>>> On Sun, Dec 1, 2013 at 2:10 PM, Ross <ross.laza...@gmail.com> wrote:
>>>
>>>> yes. In universe_wsgi_ini you have a definition for tool_dependency_dir
>>>> - that's why I wrote:
>>>>  [tool_dependency_directory]/clustalw/2.1/fubar/clustalw/76de6971a0de/  as
>>>> the path - the funny numbers are the repository revision number - that's
>>>> where the toolshed installs the binary and the env.sh file needed for the
>>>> tool to find it.
>>>>
>>>>
>>>>
>>>> On Mon, Dec 2, 2013 at 9:08 AM, Karen Miga <khm...@soe.ucsc.edu> wrote:
>>>>
>>>>> Hi Ross,
>>>>>
>>>>>    I did not detect any type of auto-install (?)  After installing
>>>>> from toolshed I did not find the binary under the /mnt/galaxy/shed_tools/
>>>>> toolshed.g2.bx.psu.edu/repos/   (or /mnt/galaxy/tools or
>>>>> /mnt/galaxy/tools/bin for that matter).  Am I looking in the wrong place?
>>>>>
>>>>> Karen
>>>>>
>>>>>
>>>>> On Sun, Dec 1, 2013 at 2:00 PM, Ross <ross.laza...@gmail.com> wrote:
>>>>>
>>>>>> Hi Karen,
>>>>>> Glad to hear it worked for you. It the tool auto-installs correctly,
>>>>>> it downloads and unpacks the binary under
>>>>>> [tool_dependency_directory]/clustalw/2.1/fubar/clustalw/76de6971a0de/ so
>>>>>> the binary you installed manually should not ever be needed by the 
>>>>>> toolshed
>>>>>> version - try moving it off your path - the tool should continue to work
>>>>>> correctly? Apologies - I should have suggested removing any manual
>>>>>> installations and their corresponding tool_conf.xml entries before using
>>>>>> the automated installation - the tool shed installation doesn't prevent 
>>>>>> you
>>>>>> from having 2 versions of the same tool in your tool menu - until those
>>>>>> manually installed ones (which may depend on clustalw2 being on the path)
>>>>>> are removed?
>>>>>>
>>>>>>
>>>>>> On Mon, Dec 2, 2013 at 8:36 AM, Karen Miga <khm...@soe.ucsc.edu>wrote:
>>>>>>
>>>>>>> Hi Ross,
>>>>>>>
>>>>>>>   Thanks for your email.  I have clustalw2 working now - I installed
>>>>>>> the clustal repository (as suggested) from toolshed and then installed 
>>>>>>> the
>>>>>>> clustalw2 binaries in our mnt/galaxy/tools/bin.
>>>>>>>
>>>>>>> Thanks again!
>>>>>>> Karen
>>>>>>>
>>>>>>>
>>>>>>> On Wed, Nov 27, 2013 at 12:46 AM, Ross <ross.laza...@gmail.com>wrote:
>>>>>>>
>>>>>>>> Hi, Karen - how did you install clustalw?
>>>>>>>> If not already done, can you please try installing the clustal
>>>>>>>> repository owned by fubar from the test toolshed through your Galaxy 
>>>>>>>> admin
>>>>>>>> interface - search/browse toolsheds? Please let me know how you go and 
>>>>>>>> if
>>>>>>>> there's a problem I'll try to fix it for you. I think there's a clustal
>>>>>>>> omega tool too but it's not one of mine. As far as I know my clustal
>>>>>>>> repository should install cleanly on a CloudMan instance.
>>>>>>>>
>>>>>>>> Sorry but we'll have to wait to from someone who knows about HyPhy.
>>>>>>>>
>>>>>>>> Hello - I am running to errors when trying to run Clustalw and
>>>>>>>> HyPhy on our cloudman instance.
>>>>>>>>
>>>>>>>> (1) Clustalw:  The program completes without error and produces an
>>>>>>>> empty file and a log file that states "/bin/sh: 1: clustalw2: not 
>>>>>>>> found"
>>>>>>>>
>>>>>>>> Searching around a bit I am not seeing clustalw2 previously
>>>>>>>> installed.  I am happy to do it if need be, however, I wanted to check 
>>>>>>>> in
>>>>>>>> and see if I am overlooking the directory or an easy fix.
>>>>>>>>
>>>>>>>> If I do need to install clustalw,  I would prefer to use
>>>>>>>> clustalw-omega, but was not sure if I needed to script a brand new 
>>>>>>>> wrapper
>>>>>>>> or if I could use the previous one that came with galaxy image.
>>>>>>>>
>>>>>>>> (2) HyPhy:  The cloud the link was initially broken.  I changed it
>>>>>>>> to the correct path:
>>>>>>>>
>>>>>>>> sudo ln -sfn /mnt/galaxy/tools/hyphy/default
>>>>>>>> /mnt/galaxy/galaxy-app/tool-data/HYPHY
>>>>>>>>
>>>>>>>> I am using a fasta alignment file of 6 protein sequences (566 AA
>>>>>>>> each) as a test case (*also fails with nucleotide alignments).
>>>>>>>>
>>>>>>>> It runs briefly and then issues an error statement "Single
>>>>>>>> Alignment Analyses Segmentation fault (core dumped)".
>>>>>>>>
>>>>>>>> Thank you in advance,
>>>>>>>>
>>>>>>>> Karen
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Karen H. Miga, PhD
>>>>>
>>>>> Postdoctoral Scholar
>>>>> University of California, Santa Cruz
>>>>> (831)459-5232
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Ross Lazarus MBBS MPH;
>>>> Head, Medical Bioinformatics, BakerIDI; Tel: +61 385321444
>>>> http://scholar.google.com/citations?hl=en&user=UCUuEM4AAAAJ
>>>>
>>>
>>>
>>>
>>> --
>>> Karen H. Miga, PhD
>>>
>>> Postdoctoral Scholar
>>> University of California, Santa Cruz
>>> (831)459-5232
>>>
>>
>>
>>
>> --
>> Ross Lazarus MBBS MPH;
>> Head, Medical Bioinformatics, BakerIDI; Tel: +61 385321444
>> http://scholar.google.com/citations?hl=en&user=UCUuEM4AAAAJ
>>
>
>
>
> --
> Karen H. Miga, PhD
>
> Postdoctoral Scholar
> University of California, Santa Cruz
> (831)459-5232
>



-- 
Ross Lazarus MBBS MPH;
Head, Medical Bioinformatics, BakerIDI; Tel: +61 385321444
http://scholar.google.com/citations?hl=en&user=UCUuEM4AAAAJ
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to