Am Dienstag, den 03.12.2013, 16:19 -0500 schrieb Mohammad Heydarian:
> Hi Bjorn,
> Thanks for the quick response. 
> 
> 
> I am running version: 10201:ebe87051fadf, when I updated to the latest
> version, I was able to start the install of DeepTools.  The tool
> seemed to be installing but when I went to refresh the page, I was
> greeted with this message: "Initializing repository installation
> failed".  

That one should not scare you. Its not an error, I need to fill a trello
card about that. But it nothing to worry about. 

> Checking on the progress of the installation with the "monitor
> installing tool shed repositories" page, shows that most of the
> repositories are "Installing tool dependencies" (yellow box) or
> "Installed, missing both tool and repository dependencies" (gray box).
> This is the case even after ~ two hours. 

Probably due to the error before. Can you please visit the deepTools
repository and choose the 'repair repository' under 'repository
actions'. That should fix all previous errors. You can also remove and
reinstall deepTools and all packages in the 'Installing' state. 

Hope that helps!
Bjoern

> 
> I am glad to clarify if my description was unclear, or even share the
> cloud instance.
> 
> 
> Thanks in advance for any help!
> 
> 
> Cheers, 
> Mo Heydarian
> 
> PhD candidate 
> The Johns Hopkins School of Medicine
> Department of Biological Chemistry 
> 725 Wolfe Street
> 402 Biophysics
> Baltimore, MD 21205
> 
> 
> On Tue, Dec 3, 2013 at 1:37 PM, Björn Grüning
> <bjoern.gruen...@pharmazie.uni-freiburg.de> wrote:
>         Hi Mohammed,
>         
>         that seems to be a old Tool Shed bug that is already fixed.
>         Which Galaxy
>         version are you running. Can you update to a more recent
>         version?
>         
>         Thanks for using Galaxy and deepTools,
>         Bjoern
>         
>         > Hello,
>         > I recently discovered the DeepTools program and have been
>         looking
>         > forward to using it with Galaxy Cloudman. Today I attempted
>         to load
>         > DeepTools from the Galaxy tool shed on my freshly started
>         Galaxy
>         > Cloudman 2.0 instance and got the following error:
>         >
>         > Internal Server Error
>         > Galaxy was unable to sucessfully complete your request
>         > URL:
>         
> http://ec2-54-226-209-68.compute-1.amazonaws.com/admin_toolshed/prepare_for_install?tool_shed_url=http://toolshed.g2.bx.psu.edu/&repository_ids=8aa7aee9b90e1791&changeset_revisions=1ee0b1ecf500
>         > Module galaxy.web.framework.middleware.error:149 in __call__
>         > >>  app_iter = self.application(environ, sr_checker)
>         > Module paste.recursive:84 in __call__
>         > >>  return self.application(environ, start_response)
>         > Module paste.httpexceptions:633 in __call__
>         > >>  return self.application(environ, start_response)
>         > Module galaxy.web.framework.base:132 in __call__
>         > >>  return self.handle_request( environ, start_response )
>         > Module galaxy.web.framework.base:190 in handle_request
>         > >>  body = method( trans, **kwargs )
>         > Module galaxy.web.framework:221 in decorator
>         > >>  return func( self, trans, *args, **kwargs )
>         > Module galaxy.webapps.galaxy.controllers.admin_toolshed:896
>         in prepare_for_install
>         > >>
>          common_install_util.get_dependencies_for_repository( trans,
>         tool_shed_url, repo_info_dict,includes_tool_dependencies )
>         > Module tool_shed.util.common_install_util:84 in
>         get_dependencies_for_repository
>         > >>  installed_rd, missing_rd =
>         
> get_installed_and_missing_repository_dependencies_for_new_install(trans, 
> repo_info_tuple )
>         > Module tool_shed.util.common_install_util:190
>         inget_installed_and_missing_repository_dependencies_for_new_install
>         > >>  tool_shed, name, owner, changeset_revision,
>         prior_installation_required
>         =suc.parse_repository_dependency_tuple( rd_tup )
>         > Module tool_shed.util.shed_util_common:1106 in
>         parse_repository_dependency_tuple
>         > >>  prior_installation_required =
>         str( prior_installation_required )
>         > UnboundLocalError: local variable
>         'prior_installation_required'
>         > referenced before assignment
>         >
>         >
>         > I got this error when I tried to install either of the three
>         revisions
>         > of the tool. Am I doing something wrong?
>         >
>         >
>         >
>         >
>         > Any guidance is appreciated! Thanks in advance!
>         >
>         >
>         > Cheers,
>         > Mo Heydarian
>         >
>         > PhD candidate
>         > The Johns Hopkins School of Medicine
>         > Department of Biological Chemistry
>         > 725 Wolfe Street
>         > 402 Biophysics
>         > Baltimore, MD 21205
>         
>         
>         
>         
> 
> 



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to