Thanks for the response Jen!

Answers to your questions below.


  1.  It should be the newest version of Galaxy
  2.   We did make production server changes but I'll check the admin part again
  3.  This might be the problem.  I tried to install package_samtools_0_1_19 
but it failed, then I installed package_samtools_0_1_18 which succeeded, and 
lastly I installed bam_to_sam
  4.  I have not tried the main galaxy instance yet.

I did mean the "same" file. I just turned off autoscaling to simplify things.
I'll get back to after: unistalling  package_samtools_0_118 and bam_to_sam and 
then just installing bam_to_sam and reviewing the how our production server is 
set up.
Thanks
Mike

From: Jennifer Jackson <j...@bx.psu.edu<mailto:j...@bx.psu.edu>>
Date: Tuesday, December 10, 2013 3:03 PM
To: Michael Mason 
<mma...@benaroyaresearch.org<mailto:mma...@benaroyaresearch.org>>, Galaxy Dev 
<galaxy-...@bx.psu.edu<mailto:galaxy-...@bx.psu.edu>>
Subject: inconsistent BAM-to-SAM behavior

Hi Mike,

I am moving this over to the 
galaxy-...@bx.psu.edu<mailto:galaxy-...@bx.psu.edu> mailing list as it concerns 
a local install. This is the best way to make contact with others working with 
the same type of Galaxy.
https://wiki.galaxyproject.org/MailingLists

A few things to provide more context that will help with troubleshooting:

1 - Are you running the most current version of Galaxy?
      https://wiki.galaxyproject.org/DevNewsBriefs (Nov 4, 2013)

2 - The local has some of the initial production server changes made?
      initial install: http://getgalaxy.org
      next steps are under: https://wiki.galaxyproject.org/Admin
      in particular: 
https://wiki.galaxyproject.org/Admin/Config/Performance/ProductionServer

3 - You installed SAMTools from the Tool Shed? The config is correct? And are 
running the latest version?
      
https://wiki.galaxyproject.org/Tool%20Shed#Installing.2C_maintaining_and_uninstalling_tool_shed_repositories_within_a_Galaxy_instance
      https://wiki.galaxyproject.org/Admin/Config/Tool%20Dependencies
      https://wiki.galaxyproject.org/Admin/Tools/Tool%20Dependencies

4 - When you run the same dataset(s) through on the public Main Galaxy instance 
at http://usegalaxy.org, is it successful or does it fail?

I wasn't sure if you meant that the same file will fail and then pass, or if 
some fail and some pass. If you could clarify that, it would help. It could 
mean the difference between a processing problem (pointing to a config or other 
issue) and a simple memory problem (where allocating more could help). Please 
keep all replies on the mailing list with a cc.

Thanks!

Jen
Galaxy team

On 12/10/13 12:07 PM, Michael Mason wrote:
Hi,

I have run some top hap output through the samtools BAM-to-SAM wrapper. It 
creates the SAM file about 50% of the time. The rest of the time it makes an 
empty file. In this case if I just rerun it often works. I was wondering if 
anyone else has seen this behavior. I am using a cloud server and think  I 
might need to change some settings. This causes my workflow to fail for many 
libraries so I also interested in any workarounds anyone has figured out.
Thanks in advance for any help.
Cheers
Mike

--
Jennifer Hillman-Jackson
http://galaxyproject.org

________________________________
--CONFIDENTIALITY NOTICE--: The information contained in this email is intended 
for the exclusive use of the addressee and may contain confidential 
information. If you are not the intended recipient, you are hereby notified 
that any form of dissemination of this communication is strictly prohibited. 
www.benaroyaresearch.org
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to