Hi Geert,

I tried to update the R package to include the libpng dependency, if you like to test it ...


http://testtoolshed.g2.bx.psu.edu/view/iuc/package_r_3_0_2

Do you know if cairo is really needed? If I can I would omit to have a dependency on cairo :)

Cheers,
Bjoern

Hi all,

I installed to package_r_2.11 and r_3x from the devteam to use as tool dependency. All installation goes fine, but when I run my tool I get the following error:

Error in png(file = "../Plots/outname.png", bg = "white", width = 480,  :
  X11 is not available

The tool uses the installed R : /galaxy/galaxy_tool_binaries/R/2.11.0/devteam/package_r_2_11_0/8d0a55bf7aaf/lib/R/bin/R

If I force the tool to use the system installed version of R, it works fine. Are there packages available in the toolsheds that allow the 'png' function to work? I already tried the R-packages from boris, but they gave compilation errors... I also tried to install the R-png package from cran as a galaxy dependency, but that didn't help either.


Thanks for the help,

Geert


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to