On Thu, Apr 17, 2014 at 12:59 AM, Saket Choudhary <sake...@gmail.com> wrote:
> I happened to copy Peter's .travis.yml for running tests for some of
> my packages.

Background information:
http://blastedbio.blogspot.co.uk/2013/09/using-travis-ci-for-testing-galaxy-tools.html

> However the process has not been smooth at all.
> See : https://travis-ci.org/saketkc/galaxy_tools/jobs/23166678#L908
>
> AssertionError: Attempting to set field 'input' to value
> '['condel_input.tabular']' in form 'tool_form' threw exception: cannot
> find value/label "condel_input.tabular" in list control
>
> I am already passing it the correct ftype :
> https://github.com/saketkc/galaxy_tools/blob/travis-test/condel_web/condel_web.xml#L22
>
> Is there something I am missing?

This is similar to (but different) to the error message I recently
reported as being unclear when a datatype was not defined:
http://lists.bx.psu.edu/pipermail/galaxy-dev/2014-April/019090.html

In your case, this is an input file which seems to be missing,
test-data/condel_input.tabular - but I see the line copying the
tool's test-data into the main Galaxy test-data folder is there
in the .travis.yml file.

I am puzzled too.

The key question I would ask you is: do your tests work locally?
If so, are they installed via a (local) Tool Shed, or manually along
the same lines of the attempted TravisCI tool installation?

Regards,

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to