Hi,

On April 16th, I did an
   hg incoming
command to update my local version of Galaxy.  Once I restarted my server, I 
was told to do 
   sh ./scripts/migrate_tools/0010_tools.sh
take care of tools which had been migrated to the tool shed.

Ever since the two changes above, I am seeing strange errors in paster.log that 
I do not understand.  Here are some samples:
(Note that Galaxy is installed in directory /birl2/Galaxy.)

-- begin paste --
galaxy.tools ERROR 2014-04-23 12:29:48,869 Error reading tool from path: 
data_source/bx_browser.xml
Traceback (most recent call last):
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 544, in 
load_tool_tag_set
    tool = self.load_tool( os.path.join( tool_path, path ), guid=guid, 
repository_id=repository_id )
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 658, in 
load_tool
    tree = load_tool( config_file )
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/loader.py", line 13, in 
load_tool
    tree = parse_xml(path)
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/util/__init__.py", line 154, in 
parse_xml
    tree = ElementTree.parse(fname)
  File 
"/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg/elementtree/ElementTree.py",
 line 859, in parse
    tree.parse(source, parser)
  File 
"/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg/elementtree/ElementTree.py",
 line 576, in parse
    source = open(source, "rb")
IOError: [Errno 2] No such file or directory: 
'./tools/data_source/bx_browser.xml'
galaxy.tools ERROR 2014-04-23 12:29:48,921 Error reading tool from path: 
data_source/flymine.xml
Traceback (most recent call last):
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 544, in 
load_tool_tag_set
    tool = self.load_tool( os.path.join( tool_path, path ), guid=guid, 
repository_id=repository_id )
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 658, in 
load_tool
    tree = load_tool( config_file )
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/loader.py", line 13, in 
load_tool
    tree = parse_xml(path)
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/util/__init__.py", line 154, in 
parse_xml
    tree = ElementTree.parse(fname)
  File 
"/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg/elementtree/ElementTree.py",
 line 859, in parse
    tree.parse(source, parser)
  File 
"/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg/elementtree/ElementTree.py",
 line 576, in parse
    source = open(source, "rb")
IOError: [Errno 2] No such file or directory: './tools/data_source/flymine.xml'
galaxy.tools ERROR 2014-04-23 12:29:48,921 Error reading tool from path: 
data_source/flymine_test.xml
Traceback (most recent call last):
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 544, in 
load_tool_tag_set
    tool = self.load_tool( os.path.join( tool_path, path ), guid=guid, 
repository_id=repository_id )
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 658, in 
load_tool
    tree = load_tool( config_file )
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/tools/loader.py", line 13, in 
load_tool
    tree = parse_xml(path)
  File "/birl2/Galaxy/galaxy-dist/lib/galaxy/util/__init__.py", line 154, in 
parse_xml
    tree = ElementTree.parse(fname)
  File 
"/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg/elementtree/ElementTree.py",
 line 859, in parse
    tree.parse(source, parser)
  File 
"/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg/elementtree/ElementTree.py",
 line 576, in parse
    source = open(source, "rb")
-- end paste --

This pattern of error messages continues for/from flymine_test.xml, 
mousemine.xml, ratmine.xml, yeastmine.xml, metabolicmine.xml, encode_db.xml, 
epigraph_import.xml, epigraph_import_test.xml, epigraph.xml, epigraph_test.xml, 
gencode_partition.xml, random_intervals.xml, column_join.xml, wiggle_to_simple, 
phastOdds_tool.xml.  The general theme is the constant reference to 
"elementtree-1.2.6_20050316-py2.7.egg".  Also of note is that an ls command 
says that /birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg 
is a regular file, and not a directory.

Within the Galaxy Admin window, I tried to search for tools (either installed 
or available) matching "ElementTree" but couldn't find anything.  Further, 
checking paster.log files from prior to having given the
  sh ./scripts/migrate_tools/0009_tools.sh
command, I see 
/birl2/Galaxy/galaxy-dist/eggs/elementtree-1.2.6_20050316-py2.7.egg mentioned 
in the python path given at the beginning of paster.log, but no error messages 
involving "ElementTree" or "elementtree".

How do I deal with this problem, and get the server to come up error free?  Any 
suggestions would be welcome.



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to