Hello,

I'm following "Managed Tool Dependencies" to the letter and still can't
get Galaxy to find the executable. Is this page
https://wiki.galaxyproject.org/Admin/Config/ToolDependencies up to date?
If yes, what am I doing wrong?

Any help greatly appreciated!


# universe_wsgi.ini
# I also tried the absolute path, it made no difference
tool_dependency_dir = tool_dependencies

# tool_dependencies is set like instructed:

$ ls tool_dependencies/hhsuite/
2.0.16/  default@
$ ls tool_dependencies/hhsuite/2.0.16/bin

ffindex_build* ffindex_get*   hhalign*       hhblits*       hhconsensus*
hhfilter*      hhmake*        hhsearch*


My tool:
<tool id="hhpred_hhblits_01" name="Create MSA from single fasta for
hhsearch" hidden="false" version="1.0.0" force_history_refresh="true">
        <requirement type="package">hhsuite</requirement>
        <description>Searches single fasta iteratively against hmm db to build a
MSA</description>
        <command>hhblits -i $input_file -d $database -oa3m $outfile</command>
etc...


Galaxy throws Error: hhblits not found.


I've tried setting the PATH in the tool_dependencies/hhsuite/2.0.16/env.sh:
#!/bin/bash
# configure PATH to hhsuite binaries
PATH="/opt/galaxy-dist/tool_dependencies/hhsuite/default/bin:$PATH"
export PATH



still getting hhblits not found :-(
What am I doing wrong?

Isabelle


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to