Thanks for the screenshot.

That page will often and regrettably report errors when there are
none. I think the advice I have been given by people who know the tool
shed better is to click install and then leave that page and go to the
list of installed repositories to track progress.

Did that samtools install ever land up working? Usually if there is a
problem with the installation the logs will be a little more clear
that there is a problem.

-John

On Tue, Oct 7, 2014 at 4:51 PM, Chris Dagdigian <d...@sonsorol.org> wrote:
>
>
> Martin Čech wrote:
>> (2) There might have been some changes to the conf syntax regarding the
>> dependency directory etc. since the version of universe.wsgi.ini that
>> you are using.  So please make sure you are using the current galaxy.ini
>> file and try installing a tool again. If it does not go well please
>> include the log of errors.
>>
>
> Still seeing mysterious tool shed installation failures on brand new
> servers running the stable checkout.
>
> After changing to HTTPS in tool_sheds_conf.xml I made much more progress
> but for a few basic tools I get the web UI stuck on "installing
> dependencies", no obvious error output and a javascript error about the
> "initializing repository installation failed" when I navigate away.
>
> Screenshot showing what happens with samtools_0_1_18 attached.
>
> And the server logs don't show anything obvious going wrong:
>
>> 50.247.195.121 - - [07/Oct/2014:20:45:41 +0000] "POST 
>> /admin_toolshed/prepare_for_install HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install?tool_shed_url=https://toolshed.g2.bx.psu.edu/&repository_ids=5a9571a9ebd4ce0a&changeset_revisions=171cd8bc208d";
>>  "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, 
>> like Gecko) Chrome/37.0.2062.124 Safari/537.36"
>> tool_shed.util.tool_dependency_util DEBUG 2014-10-07 20:45:43,539 Updating 
>> an existing record for version 0.1.18 of tool dependency samtools for 
>> revision 171cd8bc208d of repository package_samtools_0_1_18 by updating the 
>> status from Never installed to Installing.
>> tool_shed.galaxy_install.tool_dependencies.recipe.step_handler DEBUG 
>> 2014-10-07 20:45:43,563 Attempting to download via url: 
>> http://depot.galaxyproject.org/package/linux/x86_64/samtools/samtools-0.1.18-linux-x86_64.tgz
>> 50.247.195.121 - - [07/Oct/2014:20:45:45 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:45:48 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:45:51 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:45:54 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:45:57 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:00 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:03 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:06 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:09 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:13 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:16 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:19 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>> 50.247.195.121 - - [07/Oct/2014:20:46:22 +0000] "POST 
>> /admin_toolshed/repository_installation_status_updates HTTP/1.1" 200 - 
>> "http://54.165.218.123:8080/admin_toolshed/prepare_for_install"; "Mozilla/5.0 
>> (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) 
>> Chrome/37.0.2062.124 Safari/537.36"
>
>
> I'm not sure I've got the proper debug output turned on but any tips or
> hints would be appreciated.
>
> Regards,
> Chris
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to