Hi Jim,
How did you launch your instance?

If you still have the instance up, could you please also forward the first
~200 lines of /mnt/cm/paster.log (deleting any identifiable info from the
log).

Sorry abou the trouble and thanks for reporting it,
Enis

On Sat, Oct 25, 2014 at 8:58 PM, Jim White <jimwh...@uw.edu> wrote:

> When I start CloudMan following the instructions at 
> (https://wiki.galaxyproject.org/CloudMan) (ami-a7dbf6ce, Galaxy CloudMan
> 2.3) I get pretty far in the process but then Galaxy won't start because
> the EBS volumes are never mounted.  The Volume console shows that the
> volumes get created based on the public snapshots but they never go to "in
> use" which suggest that the call to mount them isn't getting done for some
> reason.  I probably will end up building my own CloudMan AMI (I'm mostly
> interested in HTCondor DAGman rather than Galaxy) but I figured you'd want
> to know about this issue.
>
> Thanks,
>
> Jim
>
> Admin 
> Console:https://dl.dropboxusercontent.com/u/73840666/CloudMan%20Trouble/Admin%20Console.png
>
> EC2 
> Volumes:https://dl.dropboxusercontent.com/u/73840666/CloudMan%20Trouble/Volumes%20OK.png
>
> Logs:
>
> Cluster status log
> 13:22:17 - Master starting
> 13:22:18 - Successfully retrieved root user's public key from file.
> 13:22:18 - Completed the initial cluster startup process. This is a new
> cluster; waiting to configure the type.
> 13:22:22 - Migration service prerequisites OK; starting the service
> 13:22:22 - SGE service prerequisites OK; starting the service
> 13:22:28 - Setting up SGE...
> 13:22:36 - Initializing 'Galaxy' cluster type with storage type 'volume'.
> Please wait...
> 13:22:40 - For filesystem galaxy, unknown kind: galaxy
> 13:22:40 - For filesystem galaxyIndices, unknown kind: galaxyIndices
> 13:22:45 - PostgreSQL data directory '/mnt/galaxy/db' does not exist (yet?)
> 13:22:46 - Adding volume vol-9fe10c87 (FS object for galaxy)...
> 13:22:46 - Could not determine next available device from frozenset([])
> 13:22:46 - Error adding file system service FS object for galaxy:
> 'NoneType' object is not iterable
> 13:22:46 - Adding volume vol-6ae10c72 (FS object for galaxyIndices)...
> 13:23:32 - Could not determine next available device from frozenset([])
> 13:23:32 - Error adding file system service FS object for galaxyIndices:
> 'NoneType' object is not iterable
> 13:23:36 - Empty disk usage for FS transient_nfs
> 13:23:36 - STATUS CHECK: File system named 'galaxy' is not mounted. Error
> code 0
> 13:23:36 - STATUS CHECK: File system named 'galaxyIndices' is not mounted.
> Error code 0
> 13:23:36 - PostgreSQL data directory '/mnt/galaxy/db' does not exist (yet?)
> 13:23:49 - Empty disk usage for FS transient_nfs
> 13:23:49 - STATUS CHECK: File system named 'galaxy' is not mounted. Error
> code 0
> 13:23:49 - STATUS CHECK: File system named 'galaxyIndices' is not mounted.
> Error code 0
> 13:23:49 - PostgreSQL data directory '/mnt/galaxy/db' does not exist (yet?)
> 13:24:01 - Empty disk usage for FS transient_nfs
> 13:24:01 - STATUS CHECK: File system named 'galaxy' is not mounted. Error
> code 0
> 13:24:01 - STATUS CHECK: File system named 'galaxyIndices' is not mounted.
> Error code 0
> 13:24:01 - PostgreSQL data directory '/mnt/galaxy/db' does not exist (yet?)
> 13:24:14 - Empty disk usage for FS transient_nfs
> 13:24:14 - STATUS CHECK: File system named 'galaxy' is not mounted. Error
> code 0
> 13:24:14 - STATUS CHECK: File system named 'galaxyIndices' is not mounted.
> Error code 0
>
> Admin Console log
> 2014-10-25 13:27:42,910 DEBUG         master:2445 Monitor adding service
> 'Galaxy'
> 2014-10-25 13:27:42,910 DEBUG       __init__:300  Galaxy service
> prerequisites are not yet satisfied, waiting for: [, , , , ]. Setting
> Galaxy service state to 'Unstarted'
> 2014-10-25 13:27:42,911 DEBUG         master:2445 Monitor adding service
> 'GalaxyReports'
> 2014-10-25 13:27:42,911 DEBUG       __init__:300  GalaxyReports service
> prerequisites are not yet satisfied, waiting for: []. Setting GalaxyReports
> service state to 'Unstarted'
> 2014-10-25 13:27:47,307 DEBUG            sge:552  qstat:
> ['al...@ip-10-158-92-92.ec2.inte BIP   0/0/1          0.33     lx24-amd64
>  ']
> 2014-10-25 13:27:47,344 WARNING   filesystem:518  Empty disk usage for FS
> transient_nfs
> 2014-10-25 13:27:47,366 ERROR     filesystem:582  STATUS CHECK: File system
> named 'galaxy' is not mounted. Error code 0
> 2014-10-25 13:27:47,390 ERROR     filesystem:582  STATUS CHECK: File system
> named 'galaxyIndices' is not mounted. Error code 0
> 2014-10-25 13:27:47,391 WARNING     postgres:199  PostgreSQL data directory
> '/mnt/galaxy/db' does not exist (yet?)
> 2014-10-25 13:27:47,404 DEBUG         master:2534 S&S:
> Migration..Completed; SGE..OK; FS object for transient_nfs..OK;
> PSS..Unstarted; FS object for galaxy..Error; FS object for
> galaxyIndices..Error; Postgres..Unstarted; ProFTPd..Unstarted;
> Galaxy..Unstarted; GalaxyReports..Unstarted;
> 2014-10-25 13:27:47,404 DEBUG         master:2445 Monitor adding service
> 'PSS'
> 2014-10-25 13:27:47,404 DEBUG            pss:87   FS object for galaxy not
> running (Error), PSS service prerequisites not met afterall,not starting
> the service yet
> 2014-10-25 13:27:47,404 DEBUG         master:2445 Monitor adding service
> 'Postgres'
> 2014-10-25 13:27:47,405 DEBUG       __init__:300  Postgres service
> prerequisites are not yet satisfied, waiting for: []. Setting Postgres
> service state to 'Unstarted'
> 2014-10-25 13:27:47,405 DEBUG         master:2445 Monitor adding service
> 'ProFTPd'
> 2014-10-25 13:27:47,405 DEBUG       __init__:300  ProFTPd service
> prerequisites are not yet satisfied, waiting for: [, ]. Setting ProFTPd
> service state to 'Unstarted'
> 2014-10-25 13:27:47,405 DEBUG         master:2445 Monitor adding service
> 'Galaxy'
> 2014-10-25 13:27:47,405 DEBUG       __init__:300  Galaxy service
> prerequisites are not yet satisfied, waiting for: [, , , , ]. Setting
> Galaxy service state to 'Unstarted'
> 2014-10-25 13:27:47,405 DEBUG         master:2445 Monitor adding service
> 'GalaxyReports'
> 2014-10-25 13:27:47,406 DEBUG       __init__:300  GalaxyReports service
> prerequisites are not yet satisfied, waiting for: []. Setting GalaxyReports
> service state to 'Unstarted'
> 2014-10-25 13:27:51,407 DEBUG         master:2445 Monitor adding service
> 'PSS'
> 2014-10-25 13:27:51,408 DEBUG            pss:87   FS object for galaxy not
> running (Error), PSS service prerequisites not met afterall,not starting
> the service yet
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to