I have followed the instructions here :

https://wiki.galaxyproject.org/Admin/Config/nginxProxy

to run a Galaxy behind an NGinx proxy under with HTTPS,
The relevant part of my NGinx config has :

            proxy_set_header REMOTE_USER "$loginOnHost";
            proxy_set_header   X-Forwarded-Host $host;
            proxy_set_header   X-Forwarded-For  $proxy_add_x_forwarded_for;
            proxy_set_header   X-URL-SCHEME https;


it is working well, with the exception that some pages are making external
 calls
to http://genome.ucsc.edu, and not https://genome.ucsc.edu .

I get a "mixed content" error (in chrome) :

I verified that the URL that the page is trying to access *does* exist
under HTTPS,
so it's just a matter of telling galaxy to generate HTTPS links. I would
have thought that
this is what "proxy_set_header   X-URL-SCHEME https;" did...


https://galaxy-1hge11q-uvd.udes.genap.ca/' was loaded over HTTPS, but
requested an insecure resource '
http://genome.ucsc.edu/cgi-bin/hgTables?GALAXY_URL=https%3A//galaxy-1hge11q…sc_table_direct1&hgta_compressType=none&sendToGalaxy=1&hgta_outputType=bed'.
This request has been blocked; the content must be served over HTTPS.


Thanks !
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to