Hi All,

I faced a problem after I tested the Bio-Blend API. I cannot access the
history anymore with the below error messages. Although, I tried
installation from the scratch, but I got the same error message. Please let
me know how to fix this problem. Thanks!

(GALAXY User Interface)

=======================================================

  "xhr": {

    "readyState": 4,

    "responseText": "{\"err_msg\": \"Uncaught exception in exposed API
method:\", \"err_code\": 0}",

    "responseJSON": {

      "err_msg": "Uncaught exception in exposed API method:",

      "err_code": 0

    },

    "status": 500,

    "statusText": "Internal Server Error",

    "responseHeaders": {

      "Date": "Wed, 03 Dec 2014 15:50:02 GMT\r",

      "cache-control": "max-age=0,no-cache,no-store\r",

      "Server": "PasteWSGIServer/0.5 Python/2.7.8\r",

      "Connection": "close\r",

      "content-type": "application/json\r"

    }

=======================================================

I found the error message in the Galaxy instance shell interface.

=======================================================

galaxy.web.framework.decorators ERROR 2014-12-03 10:50:02,279 Uncaught
exception in exposed API method:

Traceback (most recent call last):

  File "/home/bxp12/galaxy-dist/lib/galaxy/web/framework/decorators.py",
line 244, in decorator

    rval = func( self, trans, *args, **kwargs)

  File
"/home/bxp12/galaxy-ist/lib/galaxy/webapps/galaxy/api/history_contents.py",
line 76, in index

    and ( history_id == trans.security.encode_id( trans.history.id ) ) ):

AttributeError: 'NoneType' object has no attribute 'id'

=======================================================

Best,

Bongsoo
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to