Hi Alexander,
When you build the image, did you run the image cleanup step? RabbitMQ's
database needs to be cleaned up before building the image otherwise the
application won't start properly and the AMQP connection will never be
established.

You can also post the entire CloudMan's log somewhere and I can take a look
there for other clues.



On Tue, Jun 16, 2015 at 4:07 PM, Alexander Vowinkel <
vowinkel.alexan...@gmail.com> wrote:

> Maybe connected. this error (happening multiple times):
>
> ----------------------------------------
>> Exception happened during processing of request from ('127.0.0.1', 37201)
>> Traceback (most recent call last):
>>   File
>> "/home/ubuntu/.virtualenvs/CM/local/lib/python2.7/site-packages/paste/httpserver.py",
>> line 1068, in process_request_in_thread
>>     self.finish_request(request, client_address)
>>   File "/usr/lib/python2.7/SocketServer.py", line 334, in finish_request
>>     self.RequestHandlerClass(request, client_address, self)
>>   File "/usr/lib/python2.7/SocketServer.py", line 651, in __init__
>>     self.finish()
>>   File "/usr/lib/python2.7/SocketServer.py", line 710, in finish
>>     self.wfile.close()
>>   File "/usr/lib/python2.7/socket.py", line 279, in close
>>     self.flush()
>>   File "/usr/lib/python2.7/socket.py", line 303, in flush
>>     self._sock.sendall(view[write_offset:write_offset+buffer_size])
>> error: [Errno 32] Broken pipe
>> ----------------------------------------
>
>
>
> 2015-06-16 13:59 GMT-05:00 Alexander Vowinkel <
> vowinkel.alexan...@gmail.com>:
>
>> Hi,
>>
>> I have the following problem:
>> First, the job scheduling didn't work.
>>
>> I tried to upload a file, but the job was waiting.
>> Then I checked "squeue", which timed out.
>> The slurm service was running.
>>
>> Then I restarted the cluster.
>> Now I even have problems access the cloudman admin page.
>> Meaning, the page is loading endless.
>> The machine is not busy (CPU and mem @ htop)
>> In the paster.log it tries this every 4 seconds:
>>
>> 2015-06-16 18:35:56,547 DEBUG         master:2579 Trying to setup AMQP
>>> connection; conn = '<cm.util.comm.CMMasterComm object at 0x7f0aa26d72d0>'
>>> 2015-06-16 18:35:56,547 DEBUG           comm:30   Setting up a new AMQP
>>> connection
>>> 2015-06-16 18:35:56,548 DEBUG           comm:49   AMQP Connection
>>> Failure:  [Errno 111] Connection refused
>>
>>
>> Any idea what this might be?
>> Something seems to be really weird.
>>
>> I am using the next version of CloudMan (dev).
>> I created an own instance with the Cloud Man playbook.
>>
>> Best,
>> Alexander
>>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to