Hi Enis,

thank you. I will try it next time I recreate the cluster.

I have some more things:

A) I wanted to tell you that I did the update of the galaxyFS
with the playbook, by using the role cm.filesystem only.
It worked -  thanks!

B) How could I mount another volume to the upstarting cluster?

 - name: stuff
   snap_id: snap-xyz

Would that work?
E.g when I want this snapshot be mounted as /mnt/stuff

C) How can I use the dev branch of galaxy with cloudman?
There are some things only in dev I will need. How would
that be possible?

D) There is an email from me to the list from two days ago.
Could you look at that?
It's not critical for me, but might lead to a bug.

I think that's it so far.
If I have more, I'll come back to you ;)

2015-07-02 11:32 GMT-05:00 Enis Afgan <enis.af...@irb.hr>:

> Hi Alexander,
> I traced the code and tried it out and you can override what is defined in
> the flavor by providing the details in the 'Extra user data' field on the
> launch form. For example:
> filesystem_templates:
>  - name: galaxy
>    roles: galaxyTools,galaxyData
>    archive_url:
> http://s3.amazonaws.com/cloudman/fs-archives/galaxyFS-dev-latest.tar.gz
>    type: archive
>    size: 10
>  - name: galaxyIndices
>    roles: galaxyIndices
>    snap_id: snap-4b20f451
> If you want to use your custom bucket (i.e., if you have modified CloudMan
> code in some way), you can then specify it in the 'default bucket' form
> field and place cm.tar.gz and cm_boot.py in that bucket but no need to
> provide snaps.yaml.
> If you do not want to use a custom bucket, you can use the current
> 'Standard' flavor, which defaults to cloudman-test bucket with CloudMan
> from June 19th (I will not be updating anything about it until after GCC).
> Hope this helps and let me know if you have more questions,
> Enis
> On Thu, Jul 2, 2015 at 9:29 AM, Enis Afgan <enis.af...@irb.hr> wrote:
>> Hi Alexander,
>> Let me investigate this a bit more and get back to you because I was
>> under the impression I had fixed this. In the mean time, I updated your
>> flavor to specify snap-6f0b211d.
>> On Wed, Jul 1, 2015 at 4:44 PM, Alexander Vowinkel <
>> vowinkel.alexan...@gmail.com> wrote:
>>> Hi Enis,
>>> I am trying to launch my cloudman instance with this launcher again:
>>> https://launch.usegalaxy.org/launch
>>> You created the flavor for me because it wouldn't load my
>>> galaxyIndices from the snaps.yaml in my default bucket.
>>> I thought, this problem was fixed, but it still creates a galaxyIndices
>>> from the default snapshot (600GB) when using the Standard flavor.
>>> When I use my flavor, it loads the snapshot, but it is a little outdated
>>> ;)
>>> So my question: Is this behaviour expected? If no, are you going to
>>> fix it soon? If not, could you update my flavor in the way that
>>> galaxyIndices gets created from snap-6f0b211d ?
>>> Further:
>>> Should I update CM? I am still on the version from Jun 22.
>>> I am still not sure what I need to change (my snaps.yaml) in order
>>> to have my clean cluster creation still functioning.
>>> Thanks,
>>> Alexander
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to