Hello,

I've been struggling with the login issue with Galaxy for a while now. Try to 
use "incognito mode" on your browser when accessing the url for Galaxy and see 
what happens. Also if you don't really need for your users to activate their 
accounts by e-mail set the "user_activation_on=False" in galaxy.ini. You have 
to have set up your smtp server for that which can be a fuss.

Cheers,
Makis

Date: Thu, 5 Nov 2015 18:16:56 +0100
From: floreline.touch...@gmail.com
To: galaxy-dev@lists.galaxyproject.org
Subject: Re: [galaxy-dev] login problem (redirection to the login page)

Hi,
I come back to you with some news of my login problem.
I delete my browser cache and cookies with no result. 
I restart all my services (Apache, PostgreSQL, Galaxy) with no more result.
I try to start fresh with my PostgreSQL database cluster (to clear all the user 
information). But it didn't solve the problem. When I register with a user 
name, I get : 
- on the browser side:
"Now logged in as <username>@example.com.
Verification email has been sent to your email address. Please verify it by 
clicking the activation link in the email.
Please check your spam/trash folder in case you cannot find the message.
Return to the home page."
- on the server side :
"galaxy.util ERROR 2015-11-05 17:21:25,394 Mail is not configured for this 
Galaxy instance.
galaxy.util INFO 2015-11-05 17:21:25,394 From nobody Thu Nov  5 17:21:25 2015
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
To: <username>@example.com
From:
Subject: Galaxy Account Activation
Hello <user_id>,
In order to complete the activation process for <username>@example.com begun on 
11/05/15 at ip:port, please click on the following link to verify your account:
http://ip:port/activate?email=<username>%40example.com&activation_token=3285151b21c8f85590db0f0c1089110d934f2400
By clicking on the above link and opening a Galaxy account you are also 
confirming that you have read and agreed to Galaxy's Terms and Conditions for 
use of this service (None). This includes a quota limit of one account per 
user. Attempts to subvert this limit by creating multiple accounts or through 
any other method may result in termination of all associated accounts and data.
Please contact us if you need help with your account at: None. You can also 
browse resources available at: None.
More about the Galaxy Project can be found at galaxyproject.org
Your Galaxy Team"

I get a new entry in the galaxy_user table (PostgreSQl table) with "f" in the 
activate field. which I find logical.
If I activate the account with the link, the value becomes "t". Still logical.
But I'm redirected to the welcome page after the login and there's only the 
"login" and "register" options under the user tab.
I have no error on the server log.
For each connection attempt I can see this line : 
"galaxy.auth.providers.localdb DEBUG 2015-11-05 17:31:04,681 User: 
<username>@example.com, LOCALDB: True
10.80.6.195 - - [05/Nov/2015:17:31:04 +0200] "POST /user/login?use_panels=False 
HTTP/1.1" 200 - "http://ip:port/user/login"; "Mozilla/5.0 (Windows NT 6.1; 
rv:39.0) Gecko/20100101 Firefox/39.0"
10.80.6.195 - - [05/Nov/2015:17:31:04 +0200] "GET /root HTTP/1.1" 200 - 
"http://ip:port/user/login?use_panels=False"; "Mozilla/5.0 (Windows NT 6.1; 
rv:39.0) Gecko/20100101 Firefox/39.0"
10.80.6.195 - - [05/Nov/2015:17:31:05 +0200] "GET /root/welcome HTTP/1.1" 302 - 
"http://ip:port/root"; "Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 
Firefox/39.0"
"
Is it normal ?
My postgreSQl database seems to work fine.
It doesn't come from a browser cache issue (I clear mine and I try to login to 
Galaxy with another computer on the same network).
Or are there other caches I should be aware of ?
Is there another way to get an operational application ? And where did this 
issue come from ? I'm only testing the application but it surprises me since I 
had a working instance for few months. 
Thanks in advance,
F.T


2015-11-04 16:44 GMT+01:00 Floreline TOUCHARD <floreline.touch...@gmail.com>:
Update :When I clic several time on the galaxy name, I got this on the log : 
Exception happened during processing of request from ('127.0.0.1', 45055)
Traceback (most recent call last):
  File path/to/galaxy-master/eggs/Paste-1.7.5.1-py2.6.egg/paste/httpserver.py", 
line 1068, in process_request_in_thread
    self.finish_request(request, client_address)
  File "/usr/lib64/python2.6/SocketServer.py", line 332, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/lib64/python2.6/SocketServer.py", line 628, in __init__
    self.finish()
  File "/usr/lib64/python2.6/SocketServer.py", line 671, in finish
    self.wfile.flush()
  File "/usr/lib64/python2.6/socket.py", line 303, in flush
    self._sock.sendall(buffer(data, write_offset, buffer_size))
error: [Errno 32] Broken pipe
 
2015-11-04 15:09 GMT+01:00 Floreline TOUCHARD <floreline.touch...@gmail.com>:
Here is some details :when I enable the access to Galaxy without authentication 
I'm redirected to the welcome page, but still I'm not connected (I can 
login/register)
2015-11-04 14:42 GMT+01:00 Floreline TOUCHARD <floreline.touch...@gmail.com>:
Thanks for the "bidouille" ;) It didn't work for me.I have my Galaxy instance 
configured to run jobs on a cluster. I don't know where the problem come from.
2015-11-04 14:19 GMT+01:00 Yvan Le Bras <yvan.le_b...@irisa.fr>:
Hi Floreline,
Did you use several workers and/or handler ? I have had the same issue on 
Galaxy instances from our cloud, and a "not beautiful manner" I found to 
succeed authenticate was to clic several times on the galaxy name (top left of 
your instance) to force reload the page before login..... ;)
If this "bidouille" can help before you obtain a real solution to fix this..
Cheers,
Yvan
De: "Floreline TOUCHARD" <floreline.touch...@gmail.com>
À: galaxy-dev@lists.galaxyproject.org
Envoyé: Mercredi 4 Novembre 2015 14:00:24
Objet: [galaxy-dev] login problem (redirection to the login page)

Hi,
this is not the first time I encounter this problem : I change the 
authentication mode (external to internal). And since then I cannot login with 
any account. Each time I'm redirected to the login page. Yet I haven't any log 
error. I have the galaxy-master 15.07 version.
I cleared the firefox cache and cookies, from the browser and command line. But 
the problem's still there.
The last time I uninstalled my postgresql database. 
I saw this post : http://dev.list.galaxyproject.org/Login-problem-tt4139426.html
Is there a way to find the modifications (without unistall my galaxy instance) 
? 
Thanks !
F.T


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/


-- 
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Yvan Le Bras, PhD                                                               
                                                    @Yvan2935                   
                                                                                
                                           <°))))><                             
                                                             e-Biogenouest 
project                                                      
http://www.e-biogenouest.org
                                                                                
                     CNRS UMR 6074 IRISA-INRIA, Campus de Beaulieu, 35042 
Rennes Cedex
                                                                                
                                tél.:  +33 (0) 2 99 84 71 79     /      +33 (0) 
6.10.43.96.51
                                                                                
                                                             
yvan.le_b...@irisa.fr









___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/                                 
          
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to