Confirmed with a fresh galaxy checkout
commit 05ed245353331489ee443ac483b1569dab38f500
Author: Dannon Baker <dannon.ba...@gmail.com>
Date:   Thu Nov 19 20:48:16 2015 -0500

Then ran sh.run.sh to get the updates

without the additions to requirements.txt Planemo fails.

Added the four lines.

restarted the server with sh run,sh

Noticed galaxy installing twill ect

Then Planemo test worked.

===

I don't know enough about the inner workings of Galaxy to say if the adding 
these lines to requirements.txt is the correct fix or a hack that covers a 
different bug elsewhere.

Christian

PS. I noticed that if you try to use planemo against the fresh checkout without 
starting the server with run.sh Galaxy will not fetch the required updates..
I hope that is because Planemo intentional does not check if galaxy is up to 
date to safe test time. In which case I agree!


________________________________________
From: galaxy-dev [galaxy-dev-boun...@lists.galaxyproject.org] on behalf of 
Christian Brenninkmeijer [christian.brenninkmei...@manchester.ac.uk]
Sent: Friday, November 20, 2015 3:25 PM
To: John Chilton
Cc: galaxy-dev@lists.galaxyproject.org
Subject: Re: [galaxy-dev] Unable to up Planemo against latest dev

Hi John,

Yes i have vitrualenv installed.

I tried planemo both using :
brew tap galaxyproject/tap
brew install planemo

And using:
virtualenv .venv; . .venv/bin/activate
pip install planemo

With the exact same results

I also have not trouble running galaxy without the extra. bit in galaxy's 
requiremets.txt

It is Planamo that fails. But only in the builds since this weekend.

Early Galaxy builds work fine.

Christian

PS.
Ubuntu and python 2.7


________________________________________
From: John Chilton [jmchil...@gmail.com]
Sent: Friday, November 20, 2015 2:53 PM
To: Christian Brenninkmeijer
Cc: Peter Cock; galaxy-dev@lists.galaxyproject.org
Subject: Re: [galaxy-dev] Unable to up Planemo against latest dev

Do you have virtualenv installed and available to planemo? If not,
might be worth reviewing this thread -
http://dev.list.galaxyproject.org/Planemo-0-20-0-and-xunit-td4668334.html
and installing it.

In dev, virtualenv is a hard dependency for running Galaxy and this is
new, in the past Galaxy would run without it. We (Nate) may find a way
around this before the next release (16.01) specifically to allow
Galaxy to run in anaconda based environments.

If you have virtualenv installed, I really don't think Galaxy's
dependency list should require modification especially for Python 2.7,
is this for Linux or Mac OS X?

-John

On Fri, Nov 20, 2015 at 2:27 PM, Christian Brenninkmeijer
<christian.brenninkmei...@manchester.ac.uk> wrote:
> I have gotten past this stage and an now getting errors which may be my own.
>
> The fix was to edit
> https://github.com/galaxyproject/galaxy/blob/dev/lib/galaxy/dependencies/requirements.txt
> and add
> twill==1.8.0
> lxml==3.5.0
> cssselect==0.9.1
> NoseHTML==0.4.2
>
> There may well be other missing as well so that needs a look.
> For example in the old version I found an egg
> NoseTestDiff-0.1-py2.7.egg
>
> Christian
> ________________________________________
> From: Peter Cock [p.j.a.c...@googlemail.com]
> Sent: Friday, November 20, 2015 12:41 PM
> To: Christian Brenninkmeijer
> Cc: John Chilton; galaxy-dev@lists.galaxyproject.org
> Subject: Re: [galaxy-dev] Unable to up Planemo against latest dev
>
> Which file are you looking at? There is no nose entry here:
>
> https://github.com/galaxyproject/planemo/blob/master/requirements.txt
>
> Perhaps a more recent version of nose is needed?
>
> Peter
>
> On Fri, Nov 20, 2015 at 11:51 AM, Christian Brenninkmeijer
> <christian.brenninkmei...@manchester.ac.uk> wrote:
>> Hi Peter/ John
>> requirementx.txt already includes the latest version of nose
>>
>> nose==1.3.7
>>
>> It is nose that is complaining it does not like the sys,args passed in by 
>> FunctionalTest.py
>>
>> Christian
>>
>> ________________________________________
>> From: Peter Cock [p.j.a.c...@googlemail.com]
>> Sent: Friday, November 20, 2015 11:30 AM
>> To: Christian Brenninkmeijer; John Chilton
>> Cc: galaxy-dev@lists.galaxyproject.org
>> Subject: Re: [galaxy-dev] Unable to up Planemo against latest dev
>>
>> On Fri, Nov 20, 2015 at 9:59 AM, Christian Brenninkmeijer
>> <christian.brenninkmei...@manchester.ac.uk> wrote:
>>> Hi All,
>>>
>>> I am unable to run Planemo against the latest dev branch.
>>>
>>> 1. import twill error
>>>
>>> I was able to fix this by adding to requirements.txt
>>> twill==1.8.0
>>> lxml==3.5.0
>>> cssselect==0.9.1
>>>
>>> But then I get
>>>
>>> functional_tests.py: error: no such option: --with-nosehtml
>>> functional_tests.py ERROR 2015-11-20 09:57:23,066 Failure running tests
>>> Traceback (most recent call last):
>>> ...
>>> SystemExit: 2
>>
>> That's not a very helpful error, is it? It reminds me of a missing
>> dependency / installation problem I had long ago when first
>> setting up TravisCI to run Galaxy tool tests:
>>
>> https://github.com/peterjc/pico_galaxy/commit/c8265f4a42caf62eb3bc8b36b475f16cc06f1944#diff-354f30a63fb0907d4ad57269548329e3R126
>>
>> @John: My guess is we need to add "nose" to planemo's requirements.txt
>> to ensure this gets installed automatically?
>>
>> Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to