Hi

If you load a tabular table with type auto there is a possibility that it 
incorrectly sniffed as a csv file. With type csv the columns are split on 
commas and not tabs so the data appears in one column.

This is especially the case for tab separated  files that do not have row names 
and therefore the same number of tabs in the header row as the next row.

Manually change the type to tabular which will solve the problem.

One possible solution which add a stricter csv sniff method is in:

https://github.com/galaxyproject/galaxy/pull/1156

regards
Christian
University of Manchester
________________________________
From: Christian Brenninkmeijer
Sent: Wednesday, November 25, 2015 9:23 AM
To: FGiacomoni INRA
Subject: RE: [galaxy-dev] tool data_column param issue under workflow mode

Hi

If you load a tabular table with type auto there is a possibility that it 
incorrectly sniffed as a csv file. With type csv the columns are split on 
commas and not tabs.

This is especially the case for tab separated  files that do not have row names 
and therefor the same number of tabs in the header row as the next row.

Manually change the type to tabular which will solve the problem.

One possible solution which add a stricter csv sniff is in:

https://github.com/galaxyproject/galaxy/pull/1156

regards
Christian
________________________________
From: galaxy-dev [galaxy-dev-boun...@lists.galaxyproject.org] on behalf of 
FGiacomoni INRA [franck.giacom...@clermont.inra.fr]
Sent: Tuesday, November 24, 2015 2:16 PM
To: galaxy-dev@lists.galaxyproject.org
Subject: [galaxy-dev] tool data_column param issue under workflow mode

Dears,
We observed this issue under galaxy release 15.07.
Tools with a param tag and type="data_column" in their xml file are impossible 
to set on a workflow "run" mode.
The value of the column stay at "column 1" or void even if your tabular file 
has more than one column.

The setting of the tool is ok in the "analyze data" mode : you can change the 
value of the column.

We tested this issue with home made tools but also with Merge Columns (version 
1.0.1) tool - "text manipulation" section on our Galaxy instance.
and we detected the issue on the galaxy main instance too...

Any idea ?
Thanks
Marion & Franck
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to