Hi all,

I just used the subtract tool (installed under Operate on Genomic Intervals) on 
my own Galaxy server for the first time in a very long time and got this error 
message from the tool:

Traceback (most recent call last):
 line 16, in <module>
    from bx.intervals.io import GenomicInterval, NiceReaderWrapper
ImportError: No module named bx.intervals.io

So I uninstalled the intersect and subtract tools, plus the bx-python 0.7.1 
package plus the galaxy-ops package and reinstalled both tools from the 
toolshed using the latest revisions of each from devteam. I now get this error 

/Users/galaxy/galaxy-dist/lib/galaxy/__init__.py:63: UserWarning: Module bx was 
already imported from 
is being added to sys.path
Traceback (most recent call last):
 line 21, in <module>
    from utils.gff_util import GFFFeature, GFFReaderWrapper, 
ImportError: No module named utils.gff_util

Does this suggest an incompatibility somehow with the the egg which is 
installed at startup and is versions 0.7.2 - I tried manually editing the egg 
file but could not switch that to 0.7.1

I also then tried updating Galaxy to latest release 15.07 and even 15.10 which 
appeared in the git tag list as I writing this email, but no fix there - my 
Galaxy is running on a Mac OS X 10.10.5 Yosemite.

Any thoughts on how to resolve this problem?


Richard J Poole PhD
Wellcome Trust Fellow
Department of Cell and Developmental Biology
University College London
518 Rockefeller
21 University Street, London WC1E 6DE
Office (518 Rockefeller): +44 20 7679 6577 (int. 46577)
Lab (529 Rockefeller): +44 20 7679 6133 (int. 46133)

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to