Dear Peter,

Thanks for your answer. I checke all the above tings and repairing the 
repository had the effect that the above mentioned error randomly appeared at 
different dependencies of CEAS (I tried it different times and every time 
another one or two showed this error).

I finally was able to fix the issue earlier this morning by installing mysqldb 
and mysql-server directly in the docker container.

After a restart it worked.

Sorry that I didn't write before but there are additional tools that kept me 
busy.




Cheers,

Philipp


-----Original Message-----
From: Peter Briggs [mailto:peter.bri...@manchester.ac.uk] 
Sent: Dienstag, 19. Januar 2016 13:29
To: Rathert, Philipp, Dr. <philipp.rath...@ibc.uni-stuttgart.de>; Galaxy Dev 
List <galaxy-dev@lists.galaxyproject.org>
Subject: Re: [galaxy-dev] CEAS error

Hello Philipp

I'm assuming this is the 'ceas' tool from the toolshed which is owned by 
'pjbriggs' (that is me)?

If it is then from what you describe I'm not sure whether this is a problem 
with the specific tool or a more general issue with Galaxy's tool installation.

My own experiences of trying to debug tool dependency installation issues have 
been quite haphazard, and although I've seen this particular error (i.e the 
"database had no record") a few times with various tools, I've never been able 
to understand what has caused it.

First it may be worth trying the "Repair repository" option from the 
"Repository Actions" menu. If that doesn't help then I've also had some success 
in the past using the "Manage tool dependencies" option (which allows 
individual dependencies to be uninstalled and then re-installed). 
This might work if just one dependency is giving an error.

Beyond that I've found it necessary to start drilling into the Galaxy log 
files. Aside from the log of the actual Galaxy process (verbose but sometimes 
useful, I don't know how easy this is to find on your Docker instance - I don't 
have any experience of working with them), often the tool dependencies also 
create their own INSTALLATION.log files which are worth looking for/at.

The following recipe should allow you to access these from within Galaxy (this 
is for v15.10):

- Go to "Admin" -> "Manage installed tools"
- Click on the name of the tool of interest (e.g. 'ceas')
- Click on the name of an errored dependency under the "Missing tool 
dependencies" section
- In the list of dependencies, click on the name of the errored dependency again

This should take you to a page which includes a "folder browser" 
underneath the heading "Contents", where you can browse the contents of the 
installed tool dependency folder. Hopefully this will include a file called 
INSTALLATION.log, and if you click on it then the contents should be displayed 
and you can look to see if there are any error messages to indicate what went 
wrong.

Sometimes there is no INSTALLATION.log file however, in which case the main log 
file of the Galaxy process is probably the next place to look (if possible).

Sorry I don't have any more definitive answers - please let me know if any of 
the above helps.

Best wishes

Peter

On 17/01/16 18:36, Rathert, Philipp, Dr. wrote:
> Dear All,
>
>
> We are running a local docker-galaxy-stable instance on a Mac OS X 
> system. and observe a strange error:
>
>
> CEAS
> Description:
> Revision:f411ce97a351
>
> is not installing correctly.
>
> After installing mysql-python in the container directly basically 
> every package is installed:
>
> Installed tool dependencies/ - click the name to browse the dependency 
> installation directory/
> Name  Version Type    Installation status
> R
> <http://129.69.102.42/admin_toolshed/browse_tool_dependency?id=52d6bdfafedbb5e5>
> 3.1.2 package Installed
> ucsc_fetchChromSizes
> <http://129.69.102.42/admin_toolshed/browse_tool_dependency?id=ae9879a80bd0a7bc>
> 1.0   package Installed
> python_mysqldb
> <http://129.69.102.42/admin_toolshed/browse_tool_dependency?id=03552bdee8c8190f>
> 1.2.5 package Installed
> bx_python
> <http://129.69.102.42/admin_toolshed/browse_tool_dependency?id=f6509e58756240f2>
> 0.7.1 package Installed
>
>
> Missing tool dependencies/ - click the name to install the missing 
> dependency/
> Name  Version Type    Installation status
> cistrome_ceas
> <http://129.69.102.42/admin_toolshed/manage_repository_tool_dependencies?tool_dependency_ids=71b3098c1ce064d4>
> 1.0.2.d8c0751 package Error
>
> 
>
> cistrome_ceas
> <http://129.69.102.42/admin_toolshed/manage_repository_tool_dependencies?repository_id=be0a27b9edd0db03&operation=browse&tool_dependency_ids=71b3098c1ce064d4>
> 1.0.2.d8c0751 package Error
> The installation directory for this tool dependency had contents but the 
> database had no record. The installation log may show this tool dependency to 
> be correctly installed, but due to the missing database record it is now 
> being set to Error.
>
> 
>
> A reinstall results in the same error on different dependencies and 
> it looks like a random event.
>
>
> Does anybody have an idea what could solve the issue?
>
>
> I hope I provided enough information. In your answer please keep in 
> mind I am a newcomer to all this and a wet lab scientist.
>
>
> Thank you for your help.
>
>
> Cheers,
>
>
> philipp
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this and other 
> Galaxy lists, please use the interface at:
>    https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>    http://galaxyproject.org/search/mailinglists/
>

--
Peter Briggs peter.bri...@manchester.ac.uk Bioinformatics Core Facility 
University of Manchester
B.1083 Michael Smith Bldg Tel: (0161) 2751482

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to