Hi Peter,

Thanks to you and all the other responders who were so helpful! This did
solve my problem right away.

Best regards,

Scott

On Fri, Feb 26, 2016 at 3:13 PM, Peter Cock <p.j.a.c...@googlemail.com>
wrote:

> Hi Scott,
>
> Galaxy itself requires samtools (to deal with BAM files), separately
> from any Tool Dependency within the tool calling framework.
>
> Right now there is no mechanism for datatype definitions to declare a
> dependency (e.g. on a binary like samtools, or a Python library).
>
> Probably samtools should be listed as a requirement on the wiki?
> https://wiki.galaxyproject.org/Admin/GetGalaxy
>
> Peter
>
> On Fri, Feb 26, 2016 at 5:49 PM, Scott Szakonyi
> <scott.b.szakony...@nd.edu> wrote:
> > Hi,
> >
> > I'm having trouble uploading BAM files in our development environment.
> Other
> > files types are uploading without issue. I'm testing with a small BAM
> file I
> > downloaded, and I'm able to successfully upload it on our production
> server
> > and usegalaxy.org. When I try to upload in the development environment,
> I
> > get the following error:
> >
> > Traceback (most recent call last):
> >   File "/vectorbase/web/Galaxy/galaxy/tools/data_source/upload.py", line
> > 431, in <module>
> >     __main__()
> >   File "/vectorbase/web/Galaxy/galaxy/tools/data_source/upload.py", line
> > 420, in __main__
> >     add_file( dataset, registry, json_file, output_path )
> >   File "/vectorbase/web/Galaxy/galaxy/tools/data_source/upload.py", line
> > 347, in add_file
> >     if link_data_only == 'copy_files' and
> > datatype.dataset_content_needs_grooming( output_path ):
> >   File "/vectorbase/web/Galaxy/galaxy/lib/galaxy/datatypes/binary.py",
> line
> > 218, in dataset_content_needs_grooming
> >     version = self._get_samtools_version()
> >   File "/vectorbase/web/Galaxy/galaxy/lib/galaxy/datatypes/binary.py",
> line
> > 179, in _get_samtools_version
> >     raise Exception(message)
> > Exception: Attempting to use functionality requiring samtools, but it
> cannot
> > be located on Galaxy's PATH.
> >
> > I've checked my installed tools, and all the same Samtools packages are
> > successfully installed on the development environment as in production. I
> > don't see any missing dependencies or anything like that. At this point
> I'm
> > stumped. If anyone can offer some guidance on how to resolve this, I'd be
> > most appreciative.
> >
> > Best regards,
> >
> > --
> > Scott B. Szakonyi
> > Research Programmer
> >
> > Center for Research Computing
> > 107 Information Technology Center
> > Notre Dame, IN 46556
> > http://crc.nd.edu
> >
> > ___________________________________________________________
> > Please keep all replies on the list by using "reply all"
> > in your mail client.  To manage your subscriptions to this
> > and other Galaxy lists, please use the interface at:
> >   https://lists.galaxyproject.org/
> >
> > To search Galaxy mailing lists use the unified search at:
> >   http://galaxyproject.org/search/mailinglists/
>



-- 
Scott B. Szakonyi
Research Programmer

*Center for Research Computing*
107 Information Technology Center
Notre Dame, IN 46556
http://crc.nd.edu
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to