On Thu, Mar 3, 2016 at 12:06 PM, Makis Ladoukakis
<makis4e...@hotmail.com> wrote:
> Hello everyone,
>
> I've recently upgraded to Galaxy 16.01 and i have some issues with a python
> wrapper from a tool. When I run it via Galaxy I get the following error:
>
> Traceback (most recent call last):
>   File "/home/galaxy_user/galaxy/tools/myTools/know_parser/know_parser.py",
> line 12, in <module>
>     from Bio import SeqIO
> ImportError: No module named Bio
>
>
> However when I click on the "view details" icon to copy the command from the
> tool and run it on my command line the tool works perfectly. In addition
> this issue occurs while I already have installed BioPython.
>
> When I type Python and write  "from Bio import SeqIO" I get no error.
>
> Can this be an issue related to the virtual environment that is initialized
> each time Galaxy starts?
>
> Thank you in advance,
> Makis Ladoukakis

Almost certainly, yes, this is due to the new venv setup in Galaxy.

If you had manually installed Biopython, I would suggest you install it
again but inside the venv.

If you installed Biopython via the Tool Shed package, that is more troubling.
Try doing a re-install via the Tool Shed.

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to