Hi,

We, actually have problems with installation of some tools using the
galaxy web interface or the API throught the script
install_tool_shed_tools.py (
https://github.com/galaxyproject/ansible-galaxy-tools/blob/master/files/install_tool_shed_tools.py
).

When a tool has a package dependency, the dependency is installed, but
the env.sh of this dependency is not sourced at the end of its
installation and before the installation of the parent tool.

So the dependency is installed, but the parent tool installation failed
because it needs the env.sh of the depency sourced.

For example for GATK : When we install GATK, it looks up for R, which is
installed correctly but its path is not sourced so GATK installation
failled.

Any idea ? Do we have a problem in our configuration or it's a known
problem ?

Thanks in Advance for your response.

Regards,

Mikael & Fran├žoise

URGI INRA

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to