Hi Daniel,
by looking at your traceback, it seems you have a file /opt/galaxy/lib/pkg_resources.py which has been removed in Galaxy 16.01 .
To verify that you can execute

git status

which should print something like:

On branch release_16.01
Your branch is up-to-date with 'origin/release_16.01'.

Untracked files:
  (use "git add <file>..." to include in what will be committed)

    lib/pkg_resources.py

If you see that, you can remove lib/pkg_resources.py and Galaxy should work.

Cheers,
Nicola


On 19/04/16 16:54, D K wrote:
Hi Galaxy Devs,

I posted this question on biostars but didn't get an answer so I'll try here:

I just tried upgrading my local instance of Galaxy from 15.10 to 16.01. When I start it up I get an error. Does anyone have any suggestions?

|galaxy@galaxy galaxy$ sh run.sh Activating virtualenv at .venv DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6 Ignoring indexes: https://pypi.python.org/simple /opt/galaxy/.venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315 <https://pypi.python.org/simple%0A/opt/galaxy/.venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315>: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning. SNIMissingWarning /opt/galaxy/.venv/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning. InsecurePlatformWarning Requirement already up-to-date: pip==8.0.2+gx2 in ./.venv/lib/python2.6/site-packages DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6 Requirement already satisfied (use --upgrade to upgrade): bx-python==0.7.3 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 2)) Requirement already satisfied (use --upgrade to upgrade): MarkupSafe==0.23 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 3)) Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 4)) Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.8 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 5)) Requirement already satisfied (use --upgrade to upgrade): mercurial==3.4.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 7)) Requirement already satisfied (use --upgrade to upgrade): numpy==1.9.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 8)) Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 9)) Requirement already satisfied (use --upgrade to upgrade): Paste==2.0.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 16)) Requirement already satisfied (use --upgrade to upgrade): PasteDeploy==1.5.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 17)) Requirement already satisfied (use --upgrade to upgrade): docutils==0.12 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 18)) Requirement already satisfied (use --upgrade to upgrade): wchartype==0.1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 19)) Requirement already satisfied (use --upgrade to upgrade): repoze.lru==0.6 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 20)) Requirement already satisfied (use --upgrade to upgrade): Routes==2.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 21)) Requirement already satisfied (use --upgrade to upgrade): WebOb==1.4.1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 22)) Requirement already satisfied (use --upgrade to upgrade): WebHelpers==1.3 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 23)) Requirement already satisfied (use --upgrade to upgrade): Mako==1.0.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 24)) Requirement already satisfied (use --upgrade to upgrade): pytz==2015.4 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 25)) Requirement already satisfied (use --upgrade to upgrade): Babel==2.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 26)) Requirement already satisfied (use --upgrade to upgrade): Beaker==1.7.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 27)) Requirement already satisfied (use --upgrade to upgrade): Cheetah==2.4.4 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 30)) Requirement already satisfied (use --upgrade to upgrade): Markdown==2.6.3 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 31)) Requirement already satisfied (use --upgrade to upgrade): bioblend==0.6.1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 34)) Requirement already satisfied (use --upgrade to upgrade): boto==2.38.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 35)) Requirement already satisfied (use --upgrade to upgrade): requests==2.8.1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 36)) Requirement already satisfied (use --upgrade to upgrade): requests-toolbelt==0.4.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 37)) Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.30 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 40)) Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.8 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 41)) Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 42)) Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 45)) Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 46)) Requirement already satisfied (use --upgrade to upgrade): Tempita==0.5.3dev in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 47)) Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.16 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 48)) Requirement already satisfied (use --upgrade to upgrade): pbr==1.8.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 49)) Requirement already satisfied (use --upgrade to upgrade): six==1.9.0 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 51)) Requirement already satisfied (use --upgrade to upgrade): Parsley==1.3 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 52)) Requirement already satisfied (use --upgrade to upgrade): nose==1.3.7 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 53)) Requirement already satisfied (use --upgrade to upgrade): SVGFig==1.1.6 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 54)) Requirement already satisfied (use --upgrade to upgrade): Fabric==1.10.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 57)) Requirement already satisfied (use --upgrade to upgrade): paramiko==1.15.2 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 58)) Requirement already satisfied (use --upgrade to upgrade): ecdsa==0.13 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 59)) Requirement already satisfied (use --upgrade to upgrade): Whoosh==2.4.1+gx1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 66)) Requirement already satisfied (use --upgrade to upgrade): pysam==0.8.4+gx1 in ./.venv/lib/python2.6/site-packages (from -r requirements.txt (line 69)) Requirement already satisfied (use --upgrade to upgrade): importlib in ./.venv/lib/python2.6/site-packages (from kombu==3.0.30->-r requirements.txt (line 40)) Requirement already satisfied (use --upgrade to upgrade): ordereddict in ./.venv/lib/python2.6/site-packages (from kombu==3.0.30->-r requirements.txt (line 40)) You are using pip version 8.0.2+gx2, however version 8.1.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command. DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6 Requirement already satisfied (use --upgrade to upgrade): psycopg2==2.6.1 in ./.venv/lib/python2.6/site-packages (from -r /dev/stdin (line 1)) Requirement already satisfied (use --upgrade to upgrade): importlib==1.0.3 in ./.venv/lib/python2.6/site-packages (from -r /dev/stdin (line 2)) Requirement already satisfied (use --upgrade to upgrade): ordereddict==1.1 in ./.venv/lib/python2.6/site-packages (from -r /dev/stdin (line 3)) Requirement already satisfied (use --upgrade to upgrade): drmaa in ./.venv/lib/python2.6/site-packages (from -r /dev/stdin (line 4)) You are using pip version 8.0.2+gx2, however version 8.1.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Unsetting $PYTHONPATH Activating virtualenv at .venv Traceback (most recent call last): File "./scripts/paster.py", line 27, in <module> serve.run() File "/opt/galaxy/lib/galaxy/util/pastescript/serve.py", line 1061, in run invoke(command, command_name, options, args[1:]) File "/opt/galaxy/lib/galaxy/util/pastescript/serve.py", line 1067, in invoke exit_code = runner.run(args) File "/opt/galaxy/lib/galaxy/util/pastescript/serve.py", line 223, in run result = self.command() File "/opt/galaxy/lib/galaxy/util/pastescript/serve.py", line 637, in command server = loadserver(server_spec, name=server_name, relative_to=base, global_conf=vars) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 303, in loadserver return loadobj(SERVER, uri, name=name, **kw) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 319, in loadobj global_conf=global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 344, in loadcontext global_conf=global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 368, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 502, in get_context section) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 524, in _context_from_use object_type, name=use, global_conf=global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 454, in get_context global_conf=global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 344, in loadcontext global_conf=global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 376, in _loadegg return loader.get_context(object_type, name, global_conf) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 668, in get_context object_type, name=name) File "/opt/galaxy/lib/galaxy/util/pastescript/loadwsgi.py", line 688, in find_egg_entry_point pkg_resources.require(self.spec) File "/opt/galaxy/lib/pkg_resources.py", line 666, in require needed = self.resolve(parse_requirements(requirements)) File "/opt/galaxy/lib/pkg_resources.py", line 565, in resolve raise DistributionNotFound(req) # XXX put more info here pkg_resources.DistributionNotFound: Paste|


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
   https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
   http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to