Dear All,
I tried to do it.

I checked my .bashrc it was incorrect because before it was
source ~/galaxy_env/bin/activate

So when I was doing python
import library it was not working

I changed to /home/galaxy/galaxy-dist/.venv/bin/activate

Now when I am doing python then import ldap it is working well.

However now after doing bash run.sh and trying to log I have still the
problem galaxy.auth.providers.ldap_ad DEBUG 2016-05-18 10:07:35,773 LDAP
authenticate: could not load ldap module

Dont know how to check now which python the Galaxy is using ?


Mohamed



2016-05-17 15:42 GMT+02:00 Nicola Soranzo <nsora...@tiscali.it>:

> Hi Mohamed,
> you need to install python-ldap in your Python virtual environment, e.g.:
>
> $ . .venv/bin/activate
> (.venv)$ pip install python-ldap
>
> Cheers,
> Nicola
>
> ---- Mohamed Kassam ha scritto ----
>
>
> Dear all,
> I updated my galaxy this mornig to the release 16_01.
> But now my LDAP connection is nort working I have this error
>
> galaxy.auth.providers.ldap_ad DEBUG 2016-05-17 15:23:38,681 LDAP
> authenticate: could not load ldap module
>
> Do you have any idea, I checked the auth_conf.xml and it is still the same
> as the previous one.
>
>
> Mohamed
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to