Hello,

I'm having a problem with the installation of the "deeptools_bam_compare" tool (Revision: d5d57b40b29a). The installation of the requirements (package_python_2_7_deeptools_2_2_2) fails. The command which fails is the following (stderr output is located in /ceph/galaxy/tool_dependencys/deepTools/2.2.2/iuc/package_python_2_7_deeptools_2_2_2/0e67aa094608/INSTALLATION.log):


...
easy_install --no-deps --install-dir /galaxy/tool_dependencys/deepTools/2.2.2/iuc/package_python_2_7_deeptools_2_2_2/0e67aa094608 --script-dir /galaxy/tool_dependencys/deepTools/2.2.2/iuc/package_python_2_7_deeptools_2_2_2/0e67aa094608/bin deeptools_2.2.2_src_all.tar.gz


STDERR
Traceback (most recent call last):
  File "/usr/bin/easy_install", line 5, in <module>
    from pkg_resources import load_entry_point
File "/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
File "/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
File "/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
File "/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
File "/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
File "/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'setuptools==3.3' distribution was not found and is required by the application
...

The problem seems to be the missing / wrong version of setuptools. The next step for me was to check the missing tool dependencies error reports. All tool dependencies (deepTools, pysam, matplotlib, bx-python, scipy, pybigwig and numpy) show the same error with the missing setuptools. Only the package_python_2_7_10 dependency is installed correct. I checked the setuptools version in the python dependency (/ceph/galaxy/tool_dependencys/python/2.7.10/iuc/package_python_2_7_10/0339c4a9b87b/lib/python2.7/site-packages/setuptools/version.py) and it's version 18.2 (__version__ = '18.2'). This might be the problem here?

I am using Galaxy release_15.05.

Thanks,
Tobias
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to