Hi Hans-Rudolph,

This means you use 

Docker pull bgruening/galaxy-stable:latest to get the image?

 

I just noticed that the “latest” image is 6 weeks old and the other only 9 days…

 

Anyway, I will try if the problems occur with the old one as well. 

 

Did you ever tried to use Docker for mac in a production mode, if yes any idea 
how to allow acces from other computers in the network?

 

Cheers,

 

Philipp

 

From: Hans-Rudolf Hotz [mailto:hansrudolf.h...@fmi.ch] 
Sent: Wednesday, June 29, 2016 3:50 PM
To: Rathert, Philipp, Dr. <philipp.rath...@ibc.uni-stuttgart.de>
Cc: galaxy-dev@lists.galaxyproject.org
Subject: Re: [galaxy-dev] Docker for Mac

 

Hi Philipp

 

I have successfully used "Docker for Mac (beta)” on 10.11.5, but I have always 
used the traditional location for the image to fetch from: 
https://index.docker.io/u/bgruening/galaxy-stable/   (i.e just following the 
excellent recipes on https://github.com/bgruening/docker-galaxy-stable )

 

and just by coincidence:  last night I tried ' 
<http://quay.io/bgruening/galaxy:16.04'> quay.io/bgruening/galaxy:16.04' and it 
didn’t work, but I haven’t  investigated why….

 

Hans-Rudolf

 

 

On 29 Jun 2016, at 10:23, Rathert, Philipp, Dr. 
<philipp.rath...@ibc.uni-stuttgart.de 
<mailto:philipp.rath...@ibc.uni-stuttgart.de> > wrote:

 

Dear all I was wondering if anybody has experience running a galaxy production 
server using docker for mac. I know it's beta testing at the moment but since 
the Virtual machine environment gave us such a hard time preserving and 
managing user data etc. I thought I try it anyway...





However, it seems to be not as easy as expected.

 

after installation of docker I pull the new docker galaxy image with

docker pull quay.io/bgruening/ <http://quay.io/bgruening/> galaxy:16.04





When I start a test container with net=host

docker run -it --net=host quay.io/bgruening/ <http://quay.io/bgruening/> 
galaxy:16.04) 





I am not able to connect to the galaxy web app and get this  error:







Starting ProFTP

proftpd: ERROR (abnormal termination)









and 













==> /home/galaxy/logs/slurmd.log <==

[2016-06-29T08:13:41.440] error: Unable to resolve "moby": Unknown host

[2016-06-29T08:13:41.440] error: Unable to establish control machine address













I then tried to use Kinematik and at least I get the web app running. However, 
I didn't find the option to change the network settings to net=host













And I have the additional problem that I have to assign ownership rights to the 
folders in /export and I get the following error:









chown -R  <postgres:postgres> postgres:postgres /postgresql

chown: postgres: illegal group name





I know these are many issues, but maybe one of you has experience with this and 
could provide some help.





Thanks a lot,





Philipp







___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

 

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to