Thanks for your input and patience, Holger!

Please try the new version 0.4 of the weblogo wrapper in
galaxy-central #5772 - it has additional error reporting that may help
clarify dependency or other problems and let me know how you go?

On Tue, Jul 5, 2011 at 5:49 PM, Holger Klein <h.kl...@imb-mainz.de> wrote:
> Hi Ross,
>
> thanks for taking care of this issue.
>
> On 07/05/2011 12:31 AM, Ross wrote:
>
>> Is this error seen on Galaxy main or test? If so please share the
>> history with me so I can see the input and reproduce what sounds like
>> a wrapper error?
>>
>> Otherwise, if this is on a private instance, and if the tool has never
>> produced output successfully, then this may be a dependency
>> installation problem - eg you may need to ensure that the weblogo3
>> executable is available and working correctly on the path used by your
>> execution nodes. To assure yourself that your data works with the
>> tool, please try running it on main using the same data, and let me
>> know what you see?
>
> in fact it's a private instance of galaxy, it's the latest version of
> galaxy-dist (hg summary: 5743:720455407d1c).
> The input data is fine, it's a clustalw alignment in fasta format which
> can be used by the weblogo module on galaxy main.
>
> Maybe some background info on the weblogo installation helps:
> it's located below the tool_dependency_dir as defined in
> universe_wsgi.ini in weblogo/3.0 (with default as a link to 3.0). It
> contains the file env.sh which sets the PATH:
> export PATH=/home/galaxy/dependencies/weblogo/3.0:$PATH
>
> Starting the weblogo executable with the galaxy virtualenv python seems
> to work (just tested --help), although it returns a warning:
>
> ~/python/bin/python ./weblogo
> --help/home/galaxy/python/lib/python2.6/site-packages/CoreBio-0.5.0-py2.6.egg/corebio/seq_io/_nexus/__init__.py:19:
> DeprecationWarning: the sets module is deprecated
>  import sets
>
> I also tested putting a link to the weblogo executable in the PATH
> that's defined for the galaxy user (as opposed to the dependency dir
> mechanism, that I have to admit I don't fully understand yet), but that
> also doesn't work. Could this be an issue of PYTHONPATH needing to be
> adjusted?
>
> Regards,
> Holger
>
>
>
>
>
>>
>> Thanks again.
>>
>> On Tue, Jul 5, 2011 at 12:34 AM, Holger Klein <h.kl...@imb-mainz.de> wrote:
>>> Dear all,
>>>
>>> I have a problem with the weblogo tool.
>>> I have a clustalw alignment in fasta format that I'd like to visualize
>>> as a logo. The sequence logo module ends with a success (green box), the
>>> info tells me the amount and length of the input data. But the output is
>>> empty, there are no plots (no matter if I select jpg, png, pdf or text).
>>> The respective image can't be displayed "because it contains errors" or
>>> is empty in case of text.
>>>
>>> I suspect that the actual call of the weblogo tool doesn't succeed, but
>>> I didn't figure out yet on how to check this. Does anybody have hints on
>>> where to look?
>>>
>>> Cheers,
>>> Holger
>>>
>

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to