Colleen;
Yoy definitely only want to select a single security group: the CloudMan
one. Selecting multiple groups like uses the most conservative settings
in the union of the groups, so won't have the right ports open for CloudMan.

> The ami I've been mainly using is ami-da58aab3 (although I've tried a
> few others).

I don't believe this will work with NX, which would explain being able
to connect with ssh and not NX. NX requires a username/password. The
latest CloudBioLinux images do this and support CloudMan:

http://cloudbiolinux.org/

You need to enter a freenxpass: option to the user data with the
password to use for access and it will setup the server on the back
end. However, it would be worth tackling this second, after getting
CloudMan working.

> The user data may be where I am messing up:  I have a few questions
> I'm not clear on, I think I've tried may options here.. 1.  Is cluster
> name just something I make up?

Yes. It's used so you can restart the same cluster with saved data, and
have multiple clusters with different names.

> 2.  Are the <> characters part of the yaml structure?  (I've tried
> both).

No. From the log you pasted it looks like you have those around your
secret key. Could you try without it, and a single security group, on a
clean cluster and see if that fixes the issue?

>   3.  Do I need to specify the default information?

No. cluster_name, password, access_key and secret_key would be enough.

It looks like you are nearly there. Hope this does it,
Brad

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to