On Mon, Oct 24, 2011 at 9:01 AM, Appelt, Uwe
<uwe.app...@nct-heidelberg.de> wrote:
> Dear all,
>
> that has probably been asked 10e6 times, however, I don't find any comments 
> on how to properly escape special characters in a toolxy.xml. What I want to 
> achieve is the following:
>
> <command interpreter="bash">$myScript &> $logFile</command>
>
> where myScript is dynamically created (as part of the configfiles-section) 
> and the logFile is where stderr and stdout should go to. Now the problem is 
> obviously the "&"-character, because it causes the following error-msg on 
> reloading the toolxy.xml:
>
> ExpatError: not well-formed (invalid token): line 5, column 50
>
> where the 5/50 refers to the "&"-character. By the way: redirecting either 
> stdout or stderr by specifying just ">" (instead of "&>") works fine.
>
> I tried a lot of different notations in the meanwhile, but neither something 
> like "\&>" nor "\&amp;>" works. Any suggestions?
>
> Many thanks in advance and Cheers!
> Uwe

Don't you need to escape both the & and the > characters here? i.e.
&amp;&gt; should work.

Peter
___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to