I'm working on a local instance of Galaxy-dist and I just
updated it. Right after the update I tried to run the
cleanup scripts. Unfortunately what I'm getting is the
following error:

# sh delete_datasets.sh -d 0 -r
Traceback (most recent call last):
  File "./scripts/cleanup_datasets/cleanup_datasets.py",
line 524, in <module>
    if __name__ == "__main__": main()
  File "./scripts/cleanup_datasets/cleanup_datasets.py",
line 101, in main
    app = CleanupDatasetsApplication( config )
  File "./scripts/cleanup_datasets/cleanup_datasets.py",
line 512, in __init__
    self.model = galaxy.model.mapping.init(
config.file_path, config.database_connection,
engine_options={}, create_tables=False,
object_store=self.object_store )
line 1818, in init
    load_egg_for_url( url )
line 1798, in load_egg_for_url
    dialect = guess_dialect_for_url( url )
line 1794, in guess_dialect_for_url
    return (url.split(':', 1))[0]
AttributeError: 'bool' object has no attribute 'split'

The same error occurs if I try to run other cleanup
scripts, such as the delete_datasets or purge_datasets.

Any idea to solve this issue?

Best regards,
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:


To manage your subscriptions to this and other Galaxy lists,
please use the interface at:


Reply via email to