I am using GATK tools on the useGalaxy main server to detect variants in a 
mutant C. elegans whole genome sequence obtained with an Illumina instrument 
(my own data).  The first GATK tool I tried to use, Realigner Target Creator, 
gave me an error message.  In the tool window, my input file (a BAM file 
previously run through Add or  Replace Groups) did not generate an error, but 
the reference genome file (ce10) which I specified as found in History, 
produced the following reference list-specific error:  "History does not 
include a dataset of the required format/build".  I got the same error when I 
tried to use this input file to run the GATK Depth of Coverage tool.  I have 
searched Galaxy mail archives for this error, and have found other examples, 
but none involving these tools.
The ce10 database was listed in the History attributes of the BAM file I used, 
and this database has worked with all of the Galaxy tools I used up to this 
point.  Something about the ce10 format is unacceptable to GATK, or it is not 
even picking it up from the History. I don't know how to access ce10 to check 
its format.  I have only found the inbuilt reference genome files in Galaxy in 
drop-down menus for each tool.
Searching the GATK site for solutions has not been helpful, because they 
suggest GATK-specific functions to fix the format such as Create Sequence 
Dictionary.  I don't have access to these tools within the Galaxy main server.
Can someone suggest a workaround or a direct solution?

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/

Reply via email to