Hi Yupu

Just double checking: Have you restarted your Galaxy server after adding the len files?


Regards, Hans-Rudolf


On 01/28/2014 08:12 PM, Yupu Liang wrote:
Hi,

I am trying to set up the visualization functionality on our local Galaxy 
installation. I followed the instructions on  
https://wiki.galaxyproject.org/Visualization%20Setup

And here is the list of len files:
ls -l tool-data/shared/ucsc/chrom/
total 200
-rw-rw-r-- 1 galaxy galaxy    10 Jan 27 15:13 centromeres1.len
-rw-rw-r-- 1 galaxy galaxy   821 Jan 27 15:13 hg15.len
-rw-rw-r-- 1 galaxy galaxy   713 Jan 27 15:13 hg16.len
-rw-rw-r-- 1 galaxy galaxy   792 Jan 27 15:13 hg17.len
-rw-rw-r-- 1 galaxy galaxy   855 Jan 27 15:13 hg18.len
-rw-rw-r-- 1 galaxy galaxy   202 Jan 27 15:13 hg19Haps.len
-rwxr-xr-x 1 galaxy galaxy  1971 Jan 27 15:13 hg19.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hg19LggInv.len
-rw-rw-r-- 1 galaxy galaxy  4516 Jan 27 15:13 hg19Patch10.len
-rw-rw-r-- 1 galaxy galaxy  1983 Jan 27 15:13 hg19Patch2.len
-rw-rw-r-- 1 galaxy galaxy  2844 Jan 27 15:13 hg19Patch5.len
-rw-rw-r-- 1 galaxy galaxy  3879 Jan 27 15:13 hg19Patch9.len
-rw-rw-r-- 1 galaxy galaxy 11672 Jan 27 15:13 hg38.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef1.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef2.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 hlaRef3.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase0.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 repBase1.len
-rw-rw-r-- 1 galaxy galaxy 12697 Jan 27 15:13 repeats2.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHuman.len
-rw-rw-r-- 1 galaxy galaxy    67 Jan 27 15:13 simHumanMammal.len
-rw-rw-r-- 1 galaxy galaxy   362 Jan 27 15:13 venter1.len


When I test the visualization through Trackster. I got the following error after seeing a 
message saying "preparing the data, this can take a while……":

Error: The requested genome file (tool-data/shared/ucsc/chrom/hg18.len) could 
not be opened. Exiting!
sort: write failed: standard output: Broken pipe
sort: write error
Couldn't open tool-data/shared/ucsc/chrom/hg18.len , No such file or directory.


It seems something else failed in the middle of visualization as I do have the 
hg18.len under the default path with the global reading permission……..

Does anybody have similar experience? Is there is way for me to debug?

Best,
Yupu
___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

   http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

   http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

   http://galaxyproject.org/search/mailinglists/

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

 http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

 http://galaxyproject.org/search/mailinglists/

Reply via email to