[EMAIL PROTECTED] a écrit :
Salut à tous, Ca fait longtemps que je n'ai pas lancé galette et je n'arrive même plus à l'installer. Je ne comprends pas comment le positionnement initial de la langue marche.


Chez moi, ça donne ceci (voir le code ci-dessous) :
- dans install/index.php, le $pref_lang est mis à "english".
- Puis dans i18n.inc.php, comme je n'ai ni $_POST['pref_lang'], ni $_GET['pref_lang'] positionné, il est écrasé par $_SESSION["pref_lang"]
 qui est vide.
- On récupère un chaîne vide aussi pour $language.
- Après on écrase LANG par la chaîne vide et le setlocale renvoie "C".
- Ensuite on tente de charger "lang/lang_".$pref_lang.".php" qui
 n'existe pas parce que $pref_lang est vide.

Est-ce que j'ai raté quelque chose ?

Salut,

En effet, le script d'installation du CVS ne fonctionne plus. Les fichier i18n.inc.php et lang.inc.php on été fusionnés et les script d'install pas encore mis à jour. Je vais essayer dans la semaine de me pencher là dessus pour que le script d'installation soit à nouveau fonctionnel (par contre le script d'update, je le garde pour plus tard car c'est une autre paire de manches...).

D'autres pages sont aussi totalement en chantier et ne fonctionnent plus (de mémoire, visualisation d'une fiche adhérent, mailing et etiquettes, configuration des fiches...). Rien de dramatique, je n'ai juste pas encore eu le temps de les modifier pour l'utilisation d'un template.

Voilà.

Donc si tu as le courage d'essayer de faire un install à la main, ça peut fonctionner, sinon tu peux attendre mon prochain commit :)

Frédéric


Répondre à