Hello Mélissa,

Le 18/10/2012 21:43, Mélissa Djebel a écrit :
> Johan,
> 
> je viens de voir l'apparition d'une nouvelle ligne indiquant la version
> supportée dans le _define.php d'un plugin :
> 
> [...]
> 
> L'idée est qu'il faudra pour chaque nouvelle version valider son plugin
> auparavant et le mettre à jour (au moins cette ligne) sinon il sera
> désactivé par Galette ?

Non :)

Côté Galette, le changement de version ne sera effectué que s'il y a des
modifications conséquentes dans « l'API » des plugins.

Par exemple, entre la 0.7.0 et la 0.7.1 ; il y a eu une modification
dans la gestion des plugins (pour régler les histoires de chemins). De
fait, les plugins qui tournaient en 0.7.0 ne fonctionnaient plus !

Pour la 0.7.2, il n'y a pas de changements notables, la version de
compatibilité restera 0.7.1.

http://galette.tuxfamily.org/documentation/fr/development/plugins.html#compatibilite-des-plugins

> 
> Je suis mitigée :)

Le but est d'éviter que les plugins renvoient des erreurs pour rien. Ce
système ne gère par ailleurs qu'un seul cas de figure ; si quelqu'un
prend un plugin prévu pour la version 0.7.1 et le fait tourner sur une
0.7.0 ; on se retrouve dans le même cas de figure ; alors qu'il faudrait
que ce soit géré.

Si tu vois un moyen de faire autrement, je suis preneur :)

> 
> Mélissa

++
-- 
Johan

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Galette-devel mailing list
Galette-devel@gna.org
https://mail.gna.org/listinfo/galette-devel

Répondre à